summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2019-10-24 14:26:30 +0200
committerhaarp <main.haarp@gmail.com>2019-10-24 14:26:30 +0200
commit6b1021446dfe254cd2bfca6e6b7da9a73fe813fc (patch)
treea39a66a4d2b2b8efa1ef70794b1ce8a2fdaf49e4 /x11-plugins/birdtray/birdtray-1.6.ebuild
parentRestore fmod, needed by Zandronum (diff)
downloadhaarp-6b1021446dfe254cd2bfca6e6b7da9a73fe813fc.tar.gz
haarp-6b1021446dfe254cd2bfca6e6b7da9a73fe813fc.tar.bz2
haarp-6b1021446dfe254cd2bfca6e6b7da9a73fe813fc.zip
Add Birdtray (ebuild originally written by xdch47)
Signed-off-by: haarp <main.haarp@gmail.com>
Diffstat (limited to 'x11-plugins/birdtray/birdtray-1.6.ebuild')
-rw-r--r--x11-plugins/birdtray/birdtray-1.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/birdtray/birdtray-1.6.ebuild b/x11-plugins/birdtray/birdtray-1.6.ebuild
new file mode 100644
index 0000000..835fbd3
--- /dev/null
+++ b/x11-plugins/birdtray/birdtray-1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="Birdtray is a free system tray notification for new mail for Thunderbird"
+HOMEPAGE="https://github.com/gyunaev/birdtray"
+SRC_URI="https://github.com/gyunaev/${PN}/archive/RELEASE_${PV}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-db/sqlite
+ dev-qt/qtcore:5=
+ dev-qt/qtx11extras:5="
+
+S="${WORKDIR}/${PN}-RELEASE_${PV}"
+
+src_install() {
+ dobin "${BUILD_DIR}/${PN}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+pkg_postrm() {
+ xdg_icon_cache_update
+}