summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2019-10-24 14:26:30 +0200
committerhaarp <main.haarp@gmail.com>2019-10-24 14:26:30 +0200
commit6b1021446dfe254cd2bfca6e6b7da9a73fe813fc (patch)
treea39a66a4d2b2b8efa1ef70794b1ce8a2fdaf49e4 /x11-plugins
parentRestore fmod, needed by Zandronum (diff)
downloadhaarp-6b1021446dfe254cd2bfca6e6b7da9a73fe813fc.tar.gz
haarp-6b1021446dfe254cd2bfca6e6b7da9a73fe813fc.tar.bz2
haarp-6b1021446dfe254cd2bfca6e6b7da9a73fe813fc.zip
Add Birdtray (ebuild originally written by xdch47)
Signed-off-by: haarp <main.haarp@gmail.com>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/birdtray/Manifest2
-rw-r--r--x11-plugins/birdtray/birdtray-1.6.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/birdtray/Manifest b/x11-plugins/birdtray/Manifest
new file mode 100644
index 0000000..f4c56b9
--- /dev/null
+++ b/x11-plugins/birdtray/Manifest
@@ -0,0 +1,2 @@
+DIST RELEASE_1.6.tar.gz 162985 BLAKE2B cd76a56e5e5c4419c698bd160d73daae3a157ad2534709e1c2e302b9256c6717b83c72b464b92aaab7fed67d9adb86f86c13d8a282a0d00d3a20456eb9e8fe1c SHA512 b1c76cdddbbd7e16efad6fdd9f542b57fc7618a5d88525c48f0091846794c7d3ce27a3b41e4615a7d25c30028721cee3421c32a1c6f1c6dd323e29af885dc9f5
+EBUILD birdtray-1.6.ebuild 628 BLAKE2B 73b4b8eda3f02731fb50a2da7613e3e0e7e040983e467485ac591f93493106a7b6d2f306a80f3cc054e9ede111a5a0a255ecc97ebeb8b11dfa180b05997e1e00 SHA512 923521978fb9c009a91135d4f83e516f949be760cfd8b6d0050d008849ea585d182014a90a02e84a0631c68c6c0baf890522833d4e0c20c27dbdb127937e4bbd
diff --git a/x11-plugins/birdtray/birdtray-1.6.ebuild b/x11-plugins/birdtray/birdtray-1.6.ebuild
new file mode 100644
index 0000000..835fbd3
--- /dev/null
+++ b/x11-plugins/birdtray/birdtray-1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="Birdtray is a free system tray notification for new mail for Thunderbird"
+HOMEPAGE="https://github.com/gyunaev/birdtray"
+SRC_URI="https://github.com/gyunaev/${PN}/archive/RELEASE_${PV}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-db/sqlite
+ dev-qt/qtcore:5=
+ dev-qt/qtx11extras:5="
+
+S="${WORKDIR}/${PN}-RELEASE_${PV}"
+
+src_install() {
+ dobin "${BUILD_DIR}/${PN}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+pkg_postrm() {
+ xdg_icon_cache_update
+}