summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-27 23:59:18 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-27 23:59:18 -0700
commit5c45352a37147004e3c52c4c52b8ce9a3e9ff061 (patch)
tree914ad8d943bc23d2fe1cac53ab4f5f668a457097 /sys-fs/sanoid/sanoid-9999.ebuild
parentgui-libs/aquamarine: new package, add 9999 (diff)
downloadjohnmh-5c45352a37147004e3c52c4c52b8ce9a3e9ff061.tar.gz
johnmh-5c45352a37147004e3c52c4c52b8ce9a3e9ff061.tar.bz2
johnmh-5c45352a37147004e3c52c4c52b8ce9a3e9ff061.zip
sys-fs/sanoid: new package, add 2.2.0, 9999
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
Diffstat (limited to 'sys-fs/sanoid/sanoid-9999.ebuild')
-rw-r--r--sys-fs/sanoid/sanoid-9999.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-fs/sanoid/sanoid-9999.ebuild b/sys-fs/sanoid/sanoid-9999.ebuild
new file mode 100644
index 0000000..35a2551
--- /dev/null
+++ b/sys-fs/sanoid/sanoid-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Policy-driven snapshot management and replication tools for OpenZFS."
+HOMEPAGE="https://github.com/jimsalterjrs/sanoid"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jimsalterjrs/${PN^}.git"
+else
+ SRC_URI="https://github.com/jimsalterjrs/${PN^}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="gzip lzop pigz zstd"
+BDEPEND="
+ dev-lang/perl
+ sys-apps/groff
+"
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Capture-Tiny
+ dev-perl/Config-IniFiles
+ sys-apps/pv
+ sys-block/mbuffer
+ sys-fs/zfs
+ virtual/perl-Data-Dumper
+ virtual/perl-Getopt-Long
+ virtual/ssh
+ gzip? ( app-arch/gzip )
+ lzop? ( app-arch/lzop )
+ pigz? ( app-arch/pigz )
+ zstd? ( app-arch/zstd )
+"
+
+src_compile() {
+ perldoc -onroff -dsanoid.1 sanoid || die "Failed to compile sanoid.1"
+ perldoc -onroff -dsyncoid.1 syncoid || die "Failed to compile syncoid.1"
+}
+
+src_install() {
+ dobin sanoid
+ dobin syncoid
+
+ doman sanoid.1 syncoid.1
+
+ insinto /etc/sanoid
+ doins "sanoid.defaults.conf"
+
+ elog "You will need to set up your /etc/sanoid/sanoid.conf file before"
+ elog "running sanoid for the first time. For details, please consult the"
+ elog "documentation on https://github.com/jimsalterjrs/sanoid."
+}
+