summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-27 23:59:18 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-27 23:59:18 -0700
commit5c45352a37147004e3c52c4c52b8ce9a3e9ff061 (patch)
tree914ad8d943bc23d2fe1cac53ab4f5f668a457097
parentgui-libs/aquamarine: new package, add 9999 (diff)
downloadjohnmh-5c45352a37147004e3c52c4c52b8ce9a3e9ff061.tar.gz
johnmh-5c45352a37147004e3c52c4c52b8ce9a3e9ff061.tar.bz2
johnmh-5c45352a37147004e3c52c4c52b8ce9a3e9ff061.zip
sys-fs/sanoid: new package, add 2.2.0, 9999
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
-rw-r--r--sys-fs/sanoid/Manifest4
-rw-r--r--sys-fs/sanoid/metadata.xml13
-rw-r--r--sys-fs/sanoid/sanoid-2.2.0.ebuild59
-rw-r--r--sys-fs/sanoid/sanoid-9999.ebuild59
4 files changed, 135 insertions, 0 deletions
diff --git a/sys-fs/sanoid/Manifest b/sys-fs/sanoid/Manifest
new file mode 100644
index 0000000..8022746
--- /dev/null
+++ b/sys-fs/sanoid/Manifest
@@ -0,0 +1,4 @@
+DIST sanoid-2.2.0.gh.tar.gz 77865 BLAKE2B 3183ed82b392730db403dea87c72aaa9303f35227739eda5d401bd6ebe7c149977e4edca0dfd10f34c2b02932b9a5145f880425462d1e9df9d45cebf13d962bd SHA512 293c31f2da80d698987c7f06314bf6e62a54011e4028b2aa8e70d482e7757bf8ae89efe7413b8f88072bac064710ca0756650e5b6f9827a5ff50a97fd72e86ad
+EBUILD sanoid-2.2.0.ebuild 1366 BLAKE2B 925130e3f5480cfbbc6e5f1f0c19e27f0d48125fd847768bb93d4d5287e519a08921a879876fe9681fedf3a8e99d12cb0daaa12e4d3c1fd0648287f1e77515fb SHA512 b09b6c999c1de609795472c821e2b3eb04c0de453cd1747cf350ea05d0668139c299d5611856eef19e6d3a1daba4f972c3153f1400936dee24ab18fbf9579e8e
+EBUILD sanoid-9999.ebuild 1366 BLAKE2B 925130e3f5480cfbbc6e5f1f0c19e27f0d48125fd847768bb93d4d5287e519a08921a879876fe9681fedf3a8e99d12cb0daaa12e4d3c1fd0648287f1e77515fb SHA512 b09b6c999c1de609795472c821e2b3eb04c0de453cd1747cf350ea05d0668139c299d5611856eef19e6d3a1daba4f972c3153f1400936dee24ab18fbf9579e8e
+MISC metadata.xml 490 BLAKE2B 8dced77f60b8d349aa452dbe6117c2d9eab07e00268e74a2ab0c98420fc22ff480fab25b43df479bb4604347ace3384bd306a4b821e6bcdb4ef12b997dcd732d SHA512 835908e65cbcdf1f567eee358c0338d457f8bb60fe35ee275c5909b3ee4d50a3a25e8ea6254e801657f63627f04c2986f8410e91b590f6bdd94b060dbab7202c
diff --git a/sys-fs/sanoid/metadata.xml b/sys-fs/sanoid/metadata.xml
new file mode 100644
index 0000000..a99815b
--- /dev/null
+++ b/sys-fs/sanoid/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>johnmh@johnmh.me</email>
+ <name>John M. Harris, Jr.</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/jimsalterjrs/sanoid/releases</changelog>
+ <bugs-to>https://github.com/jimsalterjrs/sanoid/issues</bugs-to>
+ <remote-id type="github">jimsalterjrs/sanoid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/sanoid/sanoid-2.2.0.ebuild b/sys-fs/sanoid/sanoid-2.2.0.ebuild
new file mode 100644
index 0000000..35a2551
--- /dev/null
+++ b/sys-fs/sanoid/sanoid-2.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Policy-driven snapshot management and replication tools for OpenZFS."
+HOMEPAGE="https://github.com/jimsalterjrs/sanoid"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jimsalterjrs/${PN^}.git"
+else
+ SRC_URI="https://github.com/jimsalterjrs/${PN^}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="gzip lzop pigz zstd"
+BDEPEND="
+ dev-lang/perl
+ sys-apps/groff
+"
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Capture-Tiny
+ dev-perl/Config-IniFiles
+ sys-apps/pv
+ sys-block/mbuffer
+ sys-fs/zfs
+ virtual/perl-Data-Dumper
+ virtual/perl-Getopt-Long
+ virtual/ssh
+ gzip? ( app-arch/gzip )
+ lzop? ( app-arch/lzop )
+ pigz? ( app-arch/pigz )
+ zstd? ( app-arch/zstd )
+"
+
+src_compile() {
+ perldoc -onroff -dsanoid.1 sanoid || die "Failed to compile sanoid.1"
+ perldoc -onroff -dsyncoid.1 syncoid || die "Failed to compile syncoid.1"
+}
+
+src_install() {
+ dobin sanoid
+ dobin syncoid
+
+ doman sanoid.1 syncoid.1
+
+ insinto /etc/sanoid
+ doins "sanoid.defaults.conf"
+
+ elog "You will need to set up your /etc/sanoid/sanoid.conf file before"
+ elog "running sanoid for the first time. For details, please consult the"
+ elog "documentation on https://github.com/jimsalterjrs/sanoid."
+}
+
diff --git a/sys-fs/sanoid/sanoid-9999.ebuild b/sys-fs/sanoid/sanoid-9999.ebuild
new file mode 100644
index 0000000..35a2551
--- /dev/null
+++ b/sys-fs/sanoid/sanoid-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Policy-driven snapshot management and replication tools for OpenZFS."
+HOMEPAGE="https://github.com/jimsalterjrs/sanoid"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jimsalterjrs/${PN^}.git"
+else
+ SRC_URI="https://github.com/jimsalterjrs/${PN^}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="gzip lzop pigz zstd"
+BDEPEND="
+ dev-lang/perl
+ sys-apps/groff
+"
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Capture-Tiny
+ dev-perl/Config-IniFiles
+ sys-apps/pv
+ sys-block/mbuffer
+ sys-fs/zfs
+ virtual/perl-Data-Dumper
+ virtual/perl-Getopt-Long
+ virtual/ssh
+ gzip? ( app-arch/gzip )
+ lzop? ( app-arch/lzop )
+ pigz? ( app-arch/pigz )
+ zstd? ( app-arch/zstd )
+"
+
+src_compile() {
+ perldoc -onroff -dsanoid.1 sanoid || die "Failed to compile sanoid.1"
+ perldoc -onroff -dsyncoid.1 syncoid || die "Failed to compile syncoid.1"
+}
+
+src_install() {
+ dobin sanoid
+ dobin syncoid
+
+ doman sanoid.1 syncoid.1
+
+ insinto /etc/sanoid
+ doins "sanoid.defaults.conf"
+
+ elog "You will need to set up your /etc/sanoid/sanoid.conf file before"
+ elog "running sanoid for the first time. For details, please consult the"
+ elog "documentation on https://github.com/jimsalterjrs/sanoid."
+}
+