summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2016-05-19 11:56:36 +0900
committerBenda Xu <heroxbd@gentoo.org>2016-05-19 11:57:15 +0900
commit3b1ee209046b554b13e61e6f6056c2b072d5d684 (patch)
treed0f12de2616456389f0a22e9d750e3ba10e98ea6 /sys-devel/automake
parentsys-apps/miller: new package, initial vn. 4.0.0 (diff)
downloadgentoo-3b1ee209046b554b13e61e6f6056c2b072d5d684.tar.gz
gentoo-3b1ee209046b554b13e61e6f6056c2b072d5d684.tar.bz2
gentoo-3b1ee209046b554b13e61e6f6056c2b072d5d684.zip
sys-devel/automake: bump to EAPI5. Rework APIVERSION and pkgvdatadir.
Patch configure to leverage defaults of src_compile and src_install. pkgvdatadir now implicitly respects EPREFIX. Bug: 582734 Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-devel/automake')
-rw-r--r--sys-devel/automake/automake-1.11.6-r1.ebuild11
-rw-r--r--sys-devel/automake/automake-1.11.6-r2.ebuild11
-rw-r--r--sys-devel/automake/automake-1.12.6-r1.ebuild15
-rw-r--r--sys-devel/automake/automake-1.12.6.ebuild15
-rw-r--r--sys-devel/automake/automake-1.13.4-r1.ebuild15
-rw-r--r--sys-devel/automake/automake-1.13.4.ebuild15
-rw-r--r--sys-devel/automake/automake-1.14.1-r1.ebuild15
-rw-r--r--sys-devel/automake/automake-1.14.1.ebuild15
-rw-r--r--sys-devel/automake/automake-1.15-r1.ebuild15
-rw-r--r--sys-devel/automake/automake-1.15-r2.ebuild15
-rw-r--r--sys-devel/automake/automake-1.15.ebuild15
11 files changed, 55 insertions, 102 deletions
diff --git a/sys-devel/automake/automake-1.11.6-r1.ebuild b/sys-devel/automake/automake-1.11.6-r1.ebuild
index d44e76d09f02..ffbf60d78c67 100644
--- a/sys-devel/automake/automake-1.11.6-r1.ebuild
+++ b/sys-devel/automake/automake-1.11.6-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils
@@ -27,6 +27,7 @@ src_prepare() {
export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${PN}-1.10-perl-5.16.patch #424453
chmod a+rx tests/*.test
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
}
src_configure() {
@@ -34,7 +35,7 @@ src_configure() {
}
src_compile() {
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
local x
for x in aclocal automake; do
@@ -72,10 +73,8 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
slot_info_pages
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
rm \
"${ED}"/usr/bin/{aclocal,automake} \
diff --git a/sys-devel/automake/automake-1.11.6-r2.ebuild b/sys-devel/automake/automake-1.11.6-r2.ebuild
index 2dd5d8a1b1e2..0a179c2dd362 100644
--- a/sys-devel/automake/automake-1.11.6-r2.ebuild
+++ b/sys-devel/automake/automake-1.11.6-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils
@@ -29,6 +29,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.13-perl-escape-curly-bracket.patch
chmod a+rx tests/*.test
export HELP2MAN=true
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
}
src_configure() {
@@ -36,7 +37,7 @@ src_configure() {
}
src_compile() {
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
local x
for x in aclocal automake; do
@@ -74,10 +75,8 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
slot_info_pages
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
rm \
"${ED}"/usr/bin/{aclocal,automake} \
diff --git a/sys-devel/automake/automake-1.12.6-r1.ebuild b/sys-devel/automake/automake-1.12.6-r1.ebuild
index 390ff803f2b6..81eabe05b501 100644
--- a/sys-devel/automake/automake-1.12.6-r1.ebuild
+++ b/sys-devel/automake/automake-1.12.6-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils
@@ -26,16 +26,13 @@ DEPEND="${RDEPEND}
src_prepare() {
export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${PN}-1.13-perl-escape-curly-bracket.patch
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
}
src_configure() {
econf --docdir="\$(datarootdir)/doc/${PF}"
}
-src_compile() {
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
-}
-
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
@@ -66,13 +63,11 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
+
slot_info_pages
rm "${ED}"/usr/share/aclocal/README || die
rmdir "${ED}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
rm \
"${ED}"/usr/bin/{aclocal,automake} \
"${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
diff --git a/sys-devel/automake/automake-1.12.6.ebuild b/sys-devel/automake/automake-1.12.6.ebuild
index d95ffe38d0e0..e0eeedc19445 100644
--- a/sys-devel/automake/automake-1.12.6.ebuild
+++ b/sys-devel/automake/automake-1.12.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils
@@ -25,16 +25,13 @@ DEPEND="${RDEPEND}
src_prepare() {
export WANT_AUTOCONF=2.5
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
}
src_configure() {
econf --docdir="\$(datarootdir)/doc/${PF}"
}
-src_compile() {
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
-}
-
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
@@ -65,13 +62,11 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
+
slot_info_pages
rm "${ED}"/usr/share/aclocal/README || die
rmdir "${ED}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
rm \
"${ED}"/usr/bin/{aclocal,automake} \
"${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
diff --git a/sys-devel/automake/automake-1.13.4-r1.ebuild b/sys-devel/automake/automake-1.13.4-r1.ebuild
index 95b445cf65ce..ea2349cbecff 100644
--- a/sys-devel/automake/automake-1.13.4-r1.ebuild
+++ b/sys-devel/automake/automake-1.13.4-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils
@@ -27,16 +27,13 @@ src_prepare() {
export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${PN}-1.13-dyn-ithreads.patch
epatch "${FILESDIR}"/${PN}-1.13-perl-escape-curly-bracket.patch
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
}
src_configure() {
econf --docdir="\$(datarootdir)/doc/${PF}"
}
-src_compile() {
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
-}
-
src_test() {
emake check
}
@@ -71,13 +68,11 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
+
slot_info_pages
rm "${ED}"/usr/share/aclocal/README || die
rmdir "${ED}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
rm \
"${ED}"/usr/bin/{aclocal,automake} \
"${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
diff --git a/sys-devel/automake/automake-1.13.4.ebuild b/sys-devel/automake/automake-1.13.4.ebuild
index d70d98f5e65a..dda4afaaa415 100644
--- a/sys-devel/automake/automake-1.13.4.ebuild
+++ b/sys-devel/automake/automake-1.13.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils
@@ -26,16 +26,13 @@ DEPEND="${RDEPEND}
src_prepare() {
export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${PN}-1.13-dyn-ithreads.patch
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
}
src_configure() {
econf --docdir="\$(datarootdir)/doc/${PF}"
}
-src_compile() {
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
-}
-
src_test() {
emake check
}
@@ -70,13 +67,11 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
+
slot_info_pages
rm "${ED}"/usr/share/aclocal/README || die
rmdir "${ED}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
rm \
"${ED}"/usr/bin/{aclocal,automake} \
"${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
diff --git a/sys-devel/automake/automake-1.14.1-r1.ebuild b/sys-devel/automake/automake-1.14.1-r1.ebuild
index ed83e19cb320..23087e5480f7 100644
--- a/sys-devel/automake/automake-1.14.1-r1.ebuild
+++ b/sys-devel/automake/automake-1.14.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils versionator
@@ -39,16 +39,13 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${PN}-1.15-perl-escape-curly-bracket.patch
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
}
src_configure() {
econf --docdir="\$(datarootdir)/doc/${PF}"
}
-src_compile() {
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
-}
-
src_test() {
emake check
}
@@ -83,13 +80,11 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
+
slot_info_pages
rm "${ED}"/usr/share/aclocal/README || die
rmdir "${ED}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
rm \
"${ED}"/usr/bin/{aclocal,automake} \
"${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
diff --git a/sys-devel/automake/automake-1.14.1.ebuild b/sys-devel/automake/automake-1.14.1.ebuild
index bf80fd99e37f..ffc58058a78d 100644
--- a/sys-devel/automake/automake-1.14.1.ebuild
+++ b/sys-devel/automake/automake-1.14.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils versionator
@@ -38,16 +38,13 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
export WANT_AUTOCONF=2.5
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
}
src_configure() {
econf --docdir="\$(datarootdir)/doc/${PF}"
}
-src_compile() {
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
-}
-
src_test() {
emake check
}
@@ -82,13 +79,11 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
+
slot_info_pages
rm "${ED}"/usr/share/aclocal/README || die
rmdir "${ED}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
rm \
"${ED}"/usr/bin/{aclocal,automake} \
"${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
diff --git a/sys-devel/automake/automake-1.15-r1.ebuild b/sys-devel/automake/automake-1.15-r1.ebuild
index ed83e19cb320..23087e5480f7 100644
--- a/sys-devel/automake/automake-1.15-r1.ebuild
+++ b/sys-devel/automake/automake-1.15-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils versionator
@@ -39,16 +39,13 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${PN}-1.15-perl-escape-curly-bracket.patch
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
}
src_configure() {
econf --docdir="\$(datarootdir)/doc/${PF}"
}
-src_compile() {
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
-}
-
src_test() {
emake check
}
@@ -83,13 +80,11 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
+
slot_info_pages
rm "${ED}"/usr/share/aclocal/README || die
rmdir "${ED}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
rm \
"${ED}"/usr/bin/{aclocal,automake} \
"${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
diff --git a/sys-devel/automake/automake-1.15-r2.ebuild b/sys-devel/automake/automake-1.15-r2.ebuild
index 754d52c1f867..24668c53d485 100644
--- a/sys-devel/automake/automake-1.15-r2.ebuild
+++ b/sys-devel/automake/automake-1.15-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils versionator
@@ -40,16 +40,13 @@ src_prepare() {
export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${PN}-1.15-perl-escape-curly-bracket.patch
epatch "${FILESDIR}"/${PN}-1.15-mdate-tz.patch #520818 #574492
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
}
src_configure() {
econf --docdir="\$(datarootdir)/doc/${PF}"
}
-src_compile() {
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
-}
-
src_test() {
emake check
}
@@ -84,13 +81,11 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
+
slot_info_pages
rm "${ED}"/usr/share/aclocal/README || die
rmdir "${ED}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
rm \
"${ED}"/usr/bin/{aclocal,automake} \
"${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
diff --git a/sys-devel/automake/automake-1.15.ebuild b/sys-devel/automake/automake-1.15.ebuild
index bf80fd99e37f..ffc58058a78d 100644
--- a/sys-devel/automake/automake-1.15.ebuild
+++ b/sys-devel/automake/automake-1.15.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils versionator
@@ -38,16 +38,13 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
export WANT_AUTOCONF=2.5
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
}
src_configure() {
econf --docdir="\$(datarootdir)/doc/${PF}"
}
-src_compile() {
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
-}
-
src_test() {
emake check
}
@@ -82,13 +79,11 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
+
slot_info_pages
rm "${ED}"/usr/share/aclocal/README || die
rmdir "${ED}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
rm \
"${ED}"/usr/bin/{aclocal,automake} \
"${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die