summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake/automake-1.12.6.ebuild')
-rw-r--r--sys-devel/automake/automake-1.12.6.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/sys-devel/automake/automake-1.12.6.ebuild b/sys-devel/automake/automake-1.12.6.ebuild
index d95ffe38d0e0..e0eeedc19445 100644
--- a/sys-devel/automake/automake-1.12.6.ebuild
+++ b/sys-devel/automake/automake-1.12.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils
@@ -25,16 +25,13 @@ DEPEND="${RDEPEND}
src_prepare() {
export WANT_AUTOCONF=2.5
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
}
src_configure() {
econf --docdir="\$(datarootdir)/doc/${PF}"
}
-src_compile() {
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
-}
-
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
@@ -65,13 +62,11 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
+ default
+
slot_info_pages
rm "${ED}"/usr/share/aclocal/README || die
rmdir "${ED}"/usr/share/aclocal || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
rm \
"${ED}"/usr/bin/{aclocal,automake} \
"${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die