summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-16 14:11:25 -0700
committerMatt Turner <mattst88@gentoo.org>2022-07-18 19:04:19 -0400
commit982b84d0147119b68d6287c96fc1e33538932d52 (patch)
treedc0788613790095b6e966c679abfcdaddb6f4b42 /dev-libs
parentnet-misc/exabgp: drop 4.2.17, 4.2.20 (diff)
downloadgentoo-982b84d0147119b68d6287c96fc1e33538932d52.tar.gz
gentoo-982b84d0147119b68d6287c96fc1e33538932d52.tar.bz2
gentoo-982b84d0147119b68d6287c96fc1e33538932d52.zip
dev-libs/appstream-glib: Version bump to 0.8.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/appstream-glib/Manifest1
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.8.0.ebuild67
-rw-r--r--dev-libs/appstream-glib/files/appstream-glib-0.8.0-fix-as-self-test.patch34
3 files changed, 102 insertions, 0 deletions
diff --git a/dev-libs/appstream-glib/Manifest b/dev-libs/appstream-glib/Manifest
index 67e6ab38ac18..7423b9b1b360 100644
--- a/dev-libs/appstream-glib/Manifest
+++ b/dev-libs/appstream-glib/Manifest
@@ -1 +1,2 @@
DIST appstream-glib-0.7.18.tar.xz 2309276 BLAKE2B 67f414ae45866cab314ed2b307f2045a2035c262810696246f5bdea2a0bac88d98b561f72a8e87608f90407ad6d577d720213461ecef09d277e919b5330c0bc2 SHA512 2a202eb25d823d524128a8ab164025b6579e069f8b62373cf5447d049a0e3764fca5bf1464296101a45870d1426b094493fc8ead07a6a4bcb514c0f1a91e8ff2
+DIST appstream-glib-0.8.0.tar.xz 2315988 BLAKE2B b0858a2dccc70c3eee32262bd83a73ad739d72ca049b23387fea012c68d8dcbaec28aeaa31f81b05dee12c60a5426bdbcf1f22f5a8edbb441c663882c47b1a22 SHA512 13aeb37b8e890691a14d20ed0a86a14ae7125a6e08e60adcefe58ce2f861cebf7f49a01d9d1c137205b923f3162b307fc2671d476b7aaa9eae5fc5234ea4c1da
diff --git a/dev-libs/appstream-glib/appstream-glib-0.8.0.ebuild b/dev-libs/appstream-glib/appstream-glib-0.8.0.ebuild
new file mode 100644
index 000000000000..28cc5cc07b30
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.8.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg meson
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/ https://github.com/hughsie/appstream-glib"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="gtk-doc fonts +introspection stemmer"
+
+RDEPEND="
+ >=dev-libs/glib-2.58.0:2
+ sys-apps/util-linux
+ app-arch/libarchive:=
+ >=net-misc/curl-7.56.0
+ >=dev-libs/json-glib-1.1.2
+ >=x11-libs/gdk-pixbuf-2.31.5:2[introspection?]
+
+ fonts? (
+ x11-libs/gtk+:3
+ >=media-libs/freetype-2.4:2
+ )
+ >=media-libs/fontconfig-2.11:1.0
+ dev-libs/libyaml
+ stemmer? ( dev-libs/snowball-stemmer:= )
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-util/gperf
+
+ dev-libs/libxml2:2
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.9
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-as-self-test.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddep11=true
+ -Dbuilder=true
+ -Drpm=false
+ -Dalpm=false
+ $(meson_use fonts)
+ $(meson_use stemmer)
+ -Dman=true
+ $(meson_use gtk-doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/appstream-glib/files/appstream-glib-0.8.0-fix-as-self-test.patch b/dev-libs/appstream-glib/files/appstream-glib-0.8.0-fix-as-self-test.patch
new file mode 100644
index 000000000000..e302a04a9ce8
--- /dev/null
+++ b/dev-libs/appstream-glib/files/appstream-glib-0.8.0-fix-as-self-test.patch
@@ -0,0 +1,34 @@
+From 3870226a3585be4c31c1719248be0e17d789f3d7 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Fri, 15 Jul 2022 20:33:50 +0200
+Subject: [PATCH] Properly initialize AsNodeToXmlHelper
+
+Fixes: https://github.com/hughsie/appstream-glib/issues/445
+---
+ libappstream-glib/as-node.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libappstream-glib/as-node.c b/libappstream-glib/as-node.c
+index 4d438f5..b6650e4 100644
+--- a/libappstream-glib/as-node.c
++++ b/libappstream-glib/as-node.c
+@@ -826,7 +826,7 @@ as_node_from_xml_internal (const gchar *data, gssize data_sz,
+ AsNodeFromXmlFlags flags,
+ GError **error)
+ {
+- AsNodeToXmlHelper helper;
++ AsNodeToXmlHelper helper = {0};
+ AsNode *root = NULL;
+ gboolean ret;
+ g_autoptr(GError) error_local = NULL;
+@@ -963,7 +963,7 @@ as_node_from_file (GFile *file,
+ GCancellable *cancellable,
+ GError **error)
+ {
+- AsNodeToXmlHelper helper;
++ AsNodeToXmlHelper helper = {0};
+ GError *error_local = NULL;
+ AsNode *root = NULL;
+ const gchar *content_type = NULL;
+--
+2.35.1