summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-10-11 11:27:08 -0700
committerSam James <sam@gentoo.org>2022-10-11 20:15:00 +0100
commit232894597816812dbd20e2076a649abdbcde46f3 (patch)
tree827f9230f13d079ebb2e7e7b341bee98194921e0 /dev-libs/trio
parentvirtual/rust: Stabilize 1.64.0 ppc64, #872560 (diff)
downloadgentoo-232894597816812dbd20e2076a649abdbcde46f3.tar.gz
gentoo-232894597816812dbd20e2076a649abdbcde46f3.tar.bz2
gentoo-232894597816812dbd20e2076a649abdbcde46f3.zip
dev-libs/trio: Fix -Werror=strict-prototypes
Reference: https://archives.gentoo.org/gentoo-dev/message/dd9f2d3082b8b6f8dfbccb0639e6e240 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/27743 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/trio')
-rw-r--r--dev-libs/trio/trio-1.17.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-libs/trio/trio-1.17.ebuild b/dev-libs/trio/trio-1.17.ebuild
index a12bd3608b4d..c0cd72148b66 100644
--- a/dev-libs/trio/trio-1.17.ebuild
+++ b/dev-libs/trio/trio-1.17.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DOCS_BUILDER="doxygen"
DOCS_DIR="doc"
-inherit docs
+inherit autotools docs
DESCRIPTION="Portable string functions, focus on the *printf() and *scanf() clones"
HOMEPAGE="https://daniel.haxx.se/projects/trio/"
@@ -16,6 +16,12 @@ LICENSE="trio"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+src_prepare() {
+ default
+ # Required to fix -Werror=strict-prototypes configure errors
+ eautoreconf
+}
+
src_compile() {
default
docs_compile