summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/trio/trio-1.17.ebuild')
-rw-r--r--dev-libs/trio/trio-1.17.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-libs/trio/trio-1.17.ebuild b/dev-libs/trio/trio-1.17.ebuild
index a12bd3608b4d..c0cd72148b66 100644
--- a/dev-libs/trio/trio-1.17.ebuild
+++ b/dev-libs/trio/trio-1.17.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DOCS_BUILDER="doxygen"
DOCS_DIR="doc"
-inherit docs
+inherit autotools docs
DESCRIPTION="Portable string functions, focus on the *printf() and *scanf() clones"
HOMEPAGE="https://daniel.haxx.se/projects/trio/"
@@ -16,6 +16,12 @@ LICENSE="trio"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+src_prepare() {
+ default
+ # Required to fix -Werror=strict-prototypes configure errors
+ eautoreconf
+}
+
src_compile() {
default
docs_compile