aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteffen Christgau <mail@s14u.de>2021-02-12 21:02:00 +0100
committerSteffen Christgau <mail@s14u.de>2021-02-12 21:46:10 +0100
commit0f27a7e64f326bfb34a48769ec146a9390cdb467 (patch)
tree7fae98a69575310dc247e2e269848127809bf115 /net-misc/wsdd
parentdev-vcs/gitqlient: update live ebuild (diff)
downloadguru-0f27a7e64f326bfb34a48769ec146a9390cdb467.tar.gz
guru-0f27a7e64f326bfb34a48769ec146a9390cdb467.tar.bz2
guru-0f27a7e64f326bfb34a48769ec146a9390cdb467.zip
net-misc/wsdd: PYTHON_COMPAT update, dependency refinement
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Steffen Christgau <mail@s14u.de>
Diffstat (limited to 'net-misc/wsdd')
-rw-r--r--net-misc/wsdd/wsdd-0.5.ebuild10
-rw-r--r--net-misc/wsdd/wsdd-0.6.1.ebuild10
-rw-r--r--net-misc/wsdd/wsdd-0.6.2.ebuild10
-rw-r--r--net-misc/wsdd/wsdd-0.6.4.ebuild8
-rw-r--r--net-misc/wsdd/wsdd-0.6.ebuild10
5 files changed, 24 insertions, 24 deletions
diff --git a/net-misc/wsdd/wsdd-0.5.ebuild b/net-misc/wsdd/wsdd-0.5.ebuild
index 923d0d490..05b681d16 100644
--- a/net-misc/wsdd/wsdd-0.5.ebuild
+++ b/net-misc/wsdd/wsdd-0.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE="xml(+)"
inherit python-r1 systemd
@@ -17,9 +17,9 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE="samba"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="${PYTHON_DEPS}"
-# Samba is technically no requiredment of wsdd, but depend on it if the use flags is set.
-RDEPEND="${DEPEND} samba? ( net-fs/samba )"
+DEPEND=""
+# Samba is technically not a requirement of wsdd, but depend on it if the use flags is set.
+RDEPEND="${PYTHON_DEPS} samba? ( net-fs/samba )"
BDEPEND=""
src_install() {
diff --git a/net-misc/wsdd/wsdd-0.6.1.ebuild b/net-misc/wsdd/wsdd-0.6.1.ebuild
index f35381e5e..05b681d16 100644
--- a/net-misc/wsdd/wsdd-0.6.1.ebuild
+++ b/net-misc/wsdd/wsdd-0.6.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE="xml(+)"
inherit python-r1 systemd
@@ -17,9 +17,9 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE="samba"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="${PYTHON_DEPS}"
-# Samba is technically no requiredment of wsdd, but depend on it if the use flags is set.
-RDEPEND="${DEPEND} samba? ( net-fs/samba )"
+DEPEND=""
+# Samba is technically not a requirement of wsdd, but depend on it if the use flags is set.
+RDEPEND="${PYTHON_DEPS} samba? ( net-fs/samba )"
BDEPEND=""
src_install() {
diff --git a/net-misc/wsdd/wsdd-0.6.2.ebuild b/net-misc/wsdd/wsdd-0.6.2.ebuild
index f35381e5e..05b681d16 100644
--- a/net-misc/wsdd/wsdd-0.6.2.ebuild
+++ b/net-misc/wsdd/wsdd-0.6.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE="xml(+)"
inherit python-r1 systemd
@@ -17,9 +17,9 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE="samba"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="${PYTHON_DEPS}"
-# Samba is technically no requiredment of wsdd, but depend on it if the use flags is set.
-RDEPEND="${DEPEND} samba? ( net-fs/samba )"
+DEPEND=""
+# Samba is technically not a requirement of wsdd, but depend on it if the use flags is set.
+RDEPEND="${PYTHON_DEPS} samba? ( net-fs/samba )"
BDEPEND=""
src_install() {
diff --git a/net-misc/wsdd/wsdd-0.6.4.ebuild b/net-misc/wsdd/wsdd-0.6.4.ebuild
index f956899d8..05b681d16 100644
--- a/net-misc/wsdd/wsdd-0.6.4.ebuild
+++ b/net-misc/wsdd/wsdd-0.6.4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE="xml(+)"
inherit python-r1 systemd
@@ -17,9 +17,9 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE="samba"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="${PYTHON_DEPS}"
-# Samba is technically no requiredment of wsdd, but depend on it if the use flags is set.
-RDEPEND="${DEPEND} samba? ( net-fs/samba )"
+DEPEND=""
+# Samba is technically not a requirement of wsdd, but depend on it if the use flags is set.
+RDEPEND="${PYTHON_DEPS} samba? ( net-fs/samba )"
BDEPEND=""
src_install() {
diff --git a/net-misc/wsdd/wsdd-0.6.ebuild b/net-misc/wsdd/wsdd-0.6.ebuild
index f35381e5e..05b681d16 100644
--- a/net-misc/wsdd/wsdd-0.6.ebuild
+++ b/net-misc/wsdd/wsdd-0.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE="xml(+)"
inherit python-r1 systemd
@@ -17,9 +17,9 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE="samba"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="${PYTHON_DEPS}"
-# Samba is technically no requiredment of wsdd, but depend on it if the use flags is set.
-RDEPEND="${DEPEND} samba? ( net-fs/samba )"
+DEPEND=""
+# Samba is technically not a requirement of wsdd, but depend on it if the use flags is set.
+RDEPEND="${PYTHON_DEPS} samba? ( net-fs/samba )"
BDEPEND=""
src_install() {