summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-14 02:21:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-14 02:21:54 +0000
commit1625784a9c651dbaef813fbf7497f59989d1b444 (patch)
tree5ea256433e300be82ed3a043740e59369fc55c24 /sci-calculators/pcalc
parentadd small hack to unlink the temp file in case lex parsing failed (diff)
downloadhistorical-1625784a9c651dbaef813fbf7497f59989d1b444.tar.gz
historical-1625784a9c651dbaef813fbf7497f59989d1b444.tar.bz2
historical-1625784a9c651dbaef813fbf7497f59989d1b444.zip
fix building with newer flex
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sci-calculators/pcalc')
-rw-r--r--sci-calculators/pcalc/Manifest10
-rw-r--r--sci-calculators/pcalc/files/pcalc-1.0.0-flex.patch24
-rw-r--r--sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild3
3 files changed, 36 insertions, 1 deletions
diff --git a/sci-calculators/pcalc/Manifest b/sci-calculators/pcalc/Manifest
index 0ab3f5499895..5d7af9a27c8a 100644
--- a/sci-calculators/pcalc/Manifest
+++ b/sci-calculators/pcalc/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 25822404d543970f374c03c190602347 metadata.xml 217
MD5 3d187157454a413764f19cc250cdccdd pcalc-1.0.0-r1.ebuild 1163
MD5 050e9516a42e9449715ec6231865ed4a pcalc-1.0.0.ebuild 703
@@ -13,3 +16,10 @@ MD5 37048896f8eadea6e20d6d4ba67c2d5f files/pcalc-1.0.0-operator-updates.patch 37
MD5 b6ec72ff82cd4a5d80a40e5f8ccc6d67 files/pcalc-1.0.0-error-handler.patch 746
MD5 4d66ff33f60981fcadd27d915a6c0c7f files/pcalc-1.0.0-input-overflow-check.patch 974
MD5 a7bff3af96ba061b61898f898ee3a1ab files/pcalc-1.0.0-tmpfile.patch 2110
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFC1cyYgIKl8Uu19MoRAtSuAJ0UYaGrdYOVDWzQApjWNI8ZJCW1WgCeNnKX
+v0N2KbfqP3YpxBCxMp/gUNc=
+=qUSg
+-----END PGP SIGNATURE-----
diff --git a/sci-calculators/pcalc/files/pcalc-1.0.0-flex.patch b/sci-calculators/pcalc/files/pcalc-1.0.0-flex.patch
new file mode 100644
index 000000000000..a34c2c604725
--- /dev/null
+++ b/sci-calculators/pcalc/files/pcalc-1.0.0-flex.patch
@@ -0,0 +1,24 @@
+Tweaks so pcalc will build with flex 2.5.4a and 2.5.31.
+
+Patch by Mike Frysinger <vapier@gentoo.org>
+
+--- pcalcl.l
++++ pcalcl.l
+@@ -15,8 +15,6 @@
+ extern YYSTYPE yylval;
+ extern int lineno;
+
+-/* default yywrap function - always treat EOF as an EOF */
+-#define yywrap() 1
+
+
+ char *name;
+--- Makefile
++++ Makefile
+@@ -36,5 +36,5 @@
+
+ pcalc: $(OB0) $(OB1) $(OB2) $(OB3) $(OB4) $(OB5) $(OB6) $(OB7) $(OB8) $(OB9)
+- $(CC) $(CFLAGS) $(OB0) $(OB1) $(OB2) $(OB3) $(OB4) $(OB5) $(OB6) $(OB7) $(OB8) $(OB9) -o pcalc -lm
++ $(CC) $(CFLAGS) $(OB0) $(OB1) $(OB2) $(OB3) $(OB4) $(OB5) $(OB6) $(OB7) $(OB8) $(OB9) -o pcalc -lm -lfl
+
+ pcalc.c: pcalc.y
diff --git a/sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild b/sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild
index 04b59ba4d32e..fc9513309ac2 100644
--- a/sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild
+++ b/sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild,v 1.2 2005/06/24 11:23:56 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/pcalc/pcalc-1.0.0-r1.ebuild,v 1.3 2005/07/14 02:21:54 vapier Exp $
inherit eutils
@@ -31,6 +31,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-usage.patch
epatch "${FILESDIR}"/${P}-string-overflow-checks.patch
epatch "${FILESDIR}"/${P}-duplicated-case.patch
+ epatch "${FILESDIR}"/${P}-flex.patch
}
src_test() {