summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-14 02:21:40 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-14 02:21:40 +0000
commit3df9b451912a239ab57d6155cb207f22773bbe55 (patch)
tree05c2a5c6da6cdba5c8e1f2de31d120324277b013 /sci-calculators/pcalc
parentVersion bump #98844 by Gustavo Ribeiro Alves. (diff)
downloadhistorical-3df9b451912a239ab57d6155cb207f22773bbe55.tar.gz
historical-3df9b451912a239ab57d6155cb207f22773bbe55.tar.bz2
historical-3df9b451912a239ab57d6155cb207f22773bbe55.zip
add small hack to unlink the temp file in case lex parsing failed
Diffstat (limited to 'sci-calculators/pcalc')
-rw-r--r--sci-calculators/pcalc/Manifest17
-rw-r--r--sci-calculators/pcalc/files/pcalc-1.0.0-tmpfile.patch5
2 files changed, 13 insertions, 9 deletions
diff --git a/sci-calculators/pcalc/Manifest b/sci-calculators/pcalc/Manifest
index ee2ffad0628a..0ab3f5499895 100644
--- a/sci-calculators/pcalc/Manifest
+++ b/sci-calculators/pcalc/Manifest
@@ -1,14 +1,15 @@
-MD5 92ec1e71ede80f8a83ce4fd2d565b061 ChangeLog 931
MD5 25822404d543970f374c03c190602347 metadata.xml 217
+MD5 3d187157454a413764f19cc250cdccdd pcalc-1.0.0-r1.ebuild 1163
MD5 050e9516a42e9449715ec6231865ed4a pcalc-1.0.0.ebuild 703
-MD5 91eaf8879ca377e3e95e314d9afb00ed pcalc-1.0.0-r1.ebuild 1124
-MD5 ca434e3472d0fc8b9da24dc053a7929f files/digest-pcalc-1.0.0 61
+MD5 92ec1e71ede80f8a83ce4fd2d565b061 ChangeLog 931
MD5 ca434e3472d0fc8b9da24dc053a7929f files/digest-pcalc-1.0.0-r1 61
MD5 e36de7ac01ab409f77bf06a356099b38 files/pcalc-1.0.0-duplicated-case.patch 653
-MD5 b6ec72ff82cd4a5d80a40e5f8ccc6d67 files/pcalc-1.0.0-error-handler.patch 746
-MD5 4d66ff33f60981fcadd27d915a6c0c7f files/pcalc-1.0.0-input-overflow-check.patch 974
-MD5 37048896f8eadea6e20d6d4ba67c2d5f files/pcalc-1.0.0-operator-updates.patch 3712
-MD5 44100658fc8c1627d8d7833fa95ad814 files/pcalc-1.0.0-static-vars.patch 1118
+MD5 79bec86d6f28e3b33ac3bc5ccf040af1 files/pcalc-1.0.0-flex.patch 645
MD5 127ca758677a0ee0e12a564d390f1de6 files/pcalc-1.0.0-string-overflow-checks.patch 935
-MD5 868aa5ef1f69bce9df43d429023026d9 files/pcalc-1.0.0-tmpfile.patch 1946
+MD5 44100658fc8c1627d8d7833fa95ad814 files/pcalc-1.0.0-static-vars.patch 1118
+MD5 ca434e3472d0fc8b9da24dc053a7929f files/digest-pcalc-1.0.0 61
MD5 800c5fe897cd8901c8b5671fcb17b11f files/pcalc-1.0.0-usage.patch 785
+MD5 37048896f8eadea6e20d6d4ba67c2d5f files/pcalc-1.0.0-operator-updates.patch 3712
+MD5 b6ec72ff82cd4a5d80a40e5f8ccc6d67 files/pcalc-1.0.0-error-handler.patch 746
+MD5 4d66ff33f60981fcadd27d915a6c0c7f files/pcalc-1.0.0-input-overflow-check.patch 974
+MD5 a7bff3af96ba061b61898f898ee3a1ab files/pcalc-1.0.0-tmpfile.patch 2110
diff --git a/sci-calculators/pcalc/files/pcalc-1.0.0-tmpfile.patch b/sci-calculators/pcalc/files/pcalc-1.0.0-tmpfile.patch
index 836a0cfd74f5..372cfc9ee108 100644
--- a/sci-calculators/pcalc/files/pcalc-1.0.0-tmpfile.patch
+++ b/sci-calculators/pcalc/files/pcalc-1.0.0-tmpfile.patch
@@ -25,7 +25,7 @@ Patch by Mike Frysinger <vapier@gentoo.org>
for(cnt = args+1; cnt < argc; cnt++)
{
-@@ -207,19 +209,24 @@
+@@ -207,19 +209,27 @@
//printf("CMDLINE='%s'\n", buff);
len = strlen(buff);
@@ -56,6 +56,9 @@ Patch by Mike Frysinger <vapier@gentoo.org>
- yyin = fopen("pcalc.tmp", "r");
- comm = 1;
+ yyin = fdopen(tmpfile, "r");
++ /* XXX: hack! unlink here because if parsing fails, flex will
++ * exit and we won't be able to unlink the file below */
++ unlink(template);
}
init_sym() ;