summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 05:51:11 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 05:51:11 +0000
commite23e456240d49ba90351822151464d24267b1f73 (patch)
tree74aa9daa269ed368e7da9d3fa5ced6ad80bd1aff /games-server/halflife-hlguard
parentgames-server (diff)
downloadhistorical-e23e456240d49ba90351822151464d24267b1f73.tar.gz
historical-e23e456240d49ba90351822151464d24267b1f73.tar.bz2
historical-e23e456240d49ba90351822151464d24267b1f73.zip
games-servers !
Diffstat (limited to 'games-server/halflife-hlguard')
-rw-r--r--games-server/halflife-hlguard/ChangeLog13
-rw-r--r--games-server/halflife-hlguard/Manifest6
-rw-r--r--games-server/halflife-hlguard/files/digest-halflife-hlguard-1.411
-rw-r--r--games-server/halflife-hlguard/files/digest-halflife-hlguard-1.50.021
-rw-r--r--games-server/halflife-hlguard/files/modsetup51
-rw-r--r--games-server/halflife-hlguard/halflife-hlguard-1.41.ebuild30
-rw-r--r--games-server/halflife-hlguard/halflife-hlguard-1.50.02.ebuild34
7 files changed, 136 insertions, 0 deletions
diff --git a/games-server/halflife-hlguard/ChangeLog b/games-server/halflife-hlguard/ChangeLog
new file mode 100644
index 000000000000..28c9e5a14075
--- /dev/null
+++ b/games-server/halflife-hlguard/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-games/halflife-hlguard
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-hlguard/ChangeLog,v 1.1 2003/09/10 05:51:11 vapier Exp $
+
+*halflife-hlguard-1.50.02 (10 Aug 2003)
+
+ 10 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump + halflife-modsetup support.
+
+*halflife-hlguard-1.41 (08 Jul 2003)
+
+ 08 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-server/halflife-hlguard/Manifest b/games-server/halflife-hlguard/Manifest
new file mode 100644
index 000000000000..5bcd9c8cbaa2
--- /dev/null
+++ b/games-server/halflife-hlguard/Manifest
@@ -0,0 +1,6 @@
+MD5 808a8631750538467a9bcf2bba8b5d70 files/digest-halflife-hlguard-1.41 60
+MD5 9f40c4af0ea9c0b44083202aee530e75 files/digest-halflife-hlguard-1.50.02 63
+MD5 45da6ec4629a3110beb890fb2ad7fadf files/modsetup 1350
+MD5 185556b505ecd2ab3cb1cb0ccc36f04e halflife-hlguard-1.41.ebuild 810
+MD5 f4c361f36123be68b168d7c4c0fcf22f ChangeLog 505
+MD5 753b8e4acaf6da1bb8bfcc9a6842f12b halflife-hlguard-1.50.02.ebuild 958
diff --git a/games-server/halflife-hlguard/files/digest-halflife-hlguard-1.41 b/games-server/halflife-hlguard/files/digest-halflife-hlguard-1.41
new file mode 100644
index 000000000000..090d82f3aeb1
--- /dev/null
+++ b/games-server/halflife-hlguard/files/digest-halflife-hlguard-1.41
@@ -0,0 +1 @@
+MD5 2f534624125072281aa6f2e5852176cf hlg-1_41-en.zip 153226
diff --git a/games-server/halflife-hlguard/files/digest-halflife-hlguard-1.50.02 b/games-server/halflife-hlguard/files/digest-halflife-hlguard-1.50.02
new file mode 100644
index 000000000000..8b88e7332e04
--- /dev/null
+++ b/games-server/halflife-hlguard/files/digest-halflife-hlguard-1.50.02
@@ -0,0 +1 @@
+MD5 dcbde55435a9bde37aba5f3547b2a183 hlg-1_50_02-en.zip 615406
diff --git a/games-server/halflife-hlguard/files/modsetup b/games-server/halflife-hlguard/files/modsetup
new file mode 100644
index 000000000000..485c9e5afa97
--- /dev/null
+++ b/games-server/halflife-hlguard/files/modsetup
@@ -0,0 +1,51 @@
+#!/bin/bash
+# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-hlguard/files/modsetup,v 1.1 2003/09/10 05:51:11 vapier Exp $
+
+source GENTOO_CFGDIR/modsetup.conf || { echo "Could not find config file!" ; exit 1 ; }
+
+moddir=${PWD}
+plugindir=${moddir}/../addons/hlguard/
+
+gen_default_cfgs() {
+ mkdir ${moddir}/addons
+ ln -s ../../addons/hlguard addons/hlguard
+ #local m=${moddir}
+ #local c=${plugindir}/
+ #for f in statsme.cfg ; do
+ # [ ! -e ${m}/${f} ] \
+ # && cp ${c}/${f} ${m}/
+ #done
+}
+
+while :; do
+case $1 in
+ help)
+ file=`dialog --title "Statsme help" \
+ --menu "Select Help File:" 16 80 10 \
+ hlg_readme.txt.gz 'Basic readme' \
+ http://docs.unitedadmins.com/HLGuard/en/index.htm 'Online Docs' \
+ http://docs.unitedadmins.com/HLGuard/en/about_config_files.htm 'Config files' 2>&1`
+ [ $? -eq 0 ] || exit 0
+ [ "${file:0:4}" != "http" ] && file=/usr/share/doc/halflife-hlguard-*/${file}
+ [ "${file:${#file}-3}" == "htm" ] \
+ && ${BROWSER} ${file} \
+ || less ${file}
+ ;;
+ config)
+ gen_default_cfgs
+ file=`dialog --title "Statsme config files" \
+ --help-button \
+ --menu "Select file to Edit:" 16 80 10 \
+ hlguard.cfg 'Main configuration file' 2>&1`
+ if [ "${file:0:4}" == "HELP" ] ; then
+ $0 help
+ else
+ [ -z "${file}" ] && exit 0
+ ${EDITOR} ${moddir}/addons/hlguard/${file}
+ fi
+ ;;
+ *)
+ exit 0
+ ;;
+esac
+done
diff --git a/games-server/halflife-hlguard/halflife-hlguard-1.41.ebuild b/games-server/halflife-hlguard/halflife-hlguard-1.41.ebuild
new file mode 100644
index 000000000000..64dc84fc18c4
--- /dev/null
+++ b/games-server/halflife-hlguard/halflife-hlguard-1.41.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-hlguard/halflife-hlguard-1.41.ebuild,v 1.1 2003/09/10 05:51:11 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="server-side anti-cheat solution for Half-Life and it's many MODs"
+HOMEPAGE="http://www.unitedadmins.com/hlguard.php"
+SRC_URI="http://www.unitedadmins.com/files/hlg-${PV/./_}-en.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* x86"
+
+RDEPEND="app-games/halflife-metamod"
+
+S=${WORKDIR}/addons/hlguard
+
+src_unpack() {
+ unpack ${A}
+ edos2unix `find -name '*.txt' -o -name '*.cfg'`
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/halflife/addons/hlguard
+ dodir ${dir}
+ mv * ${D}/${dir}/
+ dodoc ${WORKDIR}/hlg_readme.txt
+ prepgamesdirs
+}
diff --git a/games-server/halflife-hlguard/halflife-hlguard-1.50.02.ebuild b/games-server/halflife-hlguard/halflife-hlguard-1.50.02.ebuild
new file mode 100644
index 000000000000..ab553805ee8e
--- /dev/null
+++ b/games-server/halflife-hlguard/halflife-hlguard-1.50.02.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-hlguard/halflife-hlguard-1.50.02.ebuild,v 1.1 2003/09/10 05:51:11 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="server-side anti-cheat solution for Half-Life and it's many MODs"
+HOMEPAGE="http://www.unitedadmins.com/hlguard.php"
+SRC_URI="http://www.unitedadmins.com/files/hlg-${PV//./_}-en.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* x86"
+
+RDEPEND="app-games/halflife-metamod
+ app-games/halflife-modsetup"
+
+S=${WORKDIR}/addons/hlguard
+
+src_unpack() {
+ unpack ${A}
+ edos2unix `find -name '*.txt' -o -name '*.cfg'`
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/halflife/addons/hlguard
+ dodir ${dir}
+ mv * ${D}/${dir}/
+ dodoc ${WORKDIR}/hlg_readme.txt
+ exeinto ${dir}
+ doexe ${FILESDIR}/modsetup
+ dosed "s:GENTOO_CFGDIR:${GAMES_SYSCONFDIR}/halflife:" ${dir}/modsetup
+ prepgamesdirs
+}