summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-server/halflife-hlguard/halflife-hlguard-1.41.ebuild')
-rw-r--r--games-server/halflife-hlguard/halflife-hlguard-1.41.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-server/halflife-hlguard/halflife-hlguard-1.41.ebuild b/games-server/halflife-hlguard/halflife-hlguard-1.41.ebuild
new file mode 100644
index 000000000000..64dc84fc18c4
--- /dev/null
+++ b/games-server/halflife-hlguard/halflife-hlguard-1.41.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-hlguard/halflife-hlguard-1.41.ebuild,v 1.1 2003/09/10 05:51:11 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="server-side anti-cheat solution for Half-Life and it's many MODs"
+HOMEPAGE="http://www.unitedadmins.com/hlguard.php"
+SRC_URI="http://www.unitedadmins.com/files/hlg-${PV/./_}-en.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* x86"
+
+RDEPEND="app-games/halflife-metamod"
+
+S=${WORKDIR}/addons/hlguard
+
+src_unpack() {
+ unpack ${A}
+ edos2unix `find -name '*.txt' -o -name '*.cfg'`
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/halflife/addons/hlguard
+ dodir ${dir}
+ mv * ${D}/${dir}/
+ dodoc ${WORKDIR}/hlg_readme.txt
+ prepgamesdirs
+}