summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commit6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3 (patch)
tree5578c0bf4dcb7768e6bc8e22c99c359d60cb6c8e /games-action/poopmup
parentgames action and arcade (diff)
downloadhistorical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.gz
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.bz2
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.zip
action games !
Diffstat (limited to 'games-action/poopmup')
-rw-r--r--games-action/poopmup/ChangeLog13
-rw-r--r--games-action/poopmup/Manifest3
-rw-r--r--games-action/poopmup/files/digest-poopmup-1.21
-rw-r--r--games-action/poopmup/poopmup-1.2.ebuild52
4 files changed, 69 insertions, 0 deletions
diff --git a/games-action/poopmup/ChangeLog b/games-action/poopmup/ChangeLog
new file mode 100644
index 000000000000..c5a14114ca06
--- /dev/null
+++ b/games-action/poopmup/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-games/poopmup
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/poopmup/ChangeLog,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+*poopmup-1.2 (23 Jun 2003)
+
+ 23 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump ... just for mkeadle ;)
+
+*poopmup-1.0 (19 Dec 2002)
+
+ 19 Dec 2002; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by mkeadle@gentoo.org.
diff --git a/games-action/poopmup/Manifest b/games-action/poopmup/Manifest
new file mode 100644
index 000000000000..4d6efc252668
--- /dev/null
+++ b/games-action/poopmup/Manifest
@@ -0,0 +1,3 @@
+MD5 ec084361c43d73ee66016449c7805e38 files/digest-poopmup-1.2 64
+MD5 8f246958433c657e9da17a3a5a6219d6 ChangeLog 475
+MD5 7d9ec6cb82b8772a4eb98829dd9a4083 poopmup-1.2.ebuild 1099
diff --git a/games-action/poopmup/files/digest-poopmup-1.2 b/games-action/poopmup/files/digest-poopmup-1.2
new file mode 100644
index 000000000000..223fbbb541be
--- /dev/null
+++ b/games-action/poopmup/files/digest-poopmup-1.2
@@ -0,0 +1 @@
+MD5 3993259bf799aa387dfa1f2d44a87ea6 poopmup-1.2.tar.gz 1461794
diff --git a/games-action/poopmup/poopmup-1.2.ebuild b/games-action/poopmup/poopmup-1.2.ebuild
new file mode 100644
index 000000000000..e3dc80a6a454
--- /dev/null
+++ b/games-action/poopmup/poopmup-1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/poopmup/poopmup-1.2.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games
+
+DESCRIPTION="You are now free to fly around the city and poop on passers-by"
+HOMEPAGE="http://poopmup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glut
+ virtual/x11
+ virtual/opengl"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/includes
+ cp textureLoader.h{,.orig}
+ sed -e "s:textures/:${GAMES_DATADIR}/${PN}/:" \
+ textureLoader.h.orig > textureLoader.h
+ cd ${S}
+ cp myConfig.h{,.orig}
+ sed -e "s:config/:${GAMES_SYSCONFDIR}/:" \
+ myConfig.h.orig > myConfig.h
+}
+
+src_compile() {
+ emake CC="${CXX:-g++} ${CFLAGS}" || die
+}
+
+src_install() {
+ rm -rf `find -name CVS`
+
+ newgamesbin poopmup.o poopmup
+
+ insinto ${GAMES_DATADIR}/${PN}
+ doins textures/*
+
+ insinto ${GAMES_SYSCONFDIR}
+ doins config/*
+
+ dodoc README docs/*.doc
+ dohtml docs/userman.htm
+
+ prepgamesdirs
+}