summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/poopmup/poopmup-1.2.ebuild')
-rw-r--r--games-action/poopmup/poopmup-1.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-action/poopmup/poopmup-1.2.ebuild b/games-action/poopmup/poopmup-1.2.ebuild
new file mode 100644
index 000000000000..e3dc80a6a454
--- /dev/null
+++ b/games-action/poopmup/poopmup-1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/poopmup/poopmup-1.2.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games
+
+DESCRIPTION="You are now free to fly around the city and poop on passers-by"
+HOMEPAGE="http://poopmup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glut
+ virtual/x11
+ virtual/opengl"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/includes
+ cp textureLoader.h{,.orig}
+ sed -e "s:textures/:${GAMES_DATADIR}/${PN}/:" \
+ textureLoader.h.orig > textureLoader.h
+ cd ${S}
+ cp myConfig.h{,.orig}
+ sed -e "s:config/:${GAMES_SYSCONFDIR}/:" \
+ myConfig.h.orig > myConfig.h
+}
+
+src_compile() {
+ emake CC="${CXX:-g++} ${CFLAGS}" || die
+}
+
+src_install() {
+ rm -rf `find -name CVS`
+
+ newgamesbin poopmup.o poopmup
+
+ insinto ${GAMES_DATADIR}/${PN}
+ doins textures/*
+
+ insinto ${GAMES_SYSCONFDIR}
+ doins config/*
+
+ dodoc README docs/*.doc
+ dohtml docs/userman.htm
+
+ prepgamesdirs
+}