summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-26 01:45:41 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-26 01:45:41 +0000
commitd5e3bddd7a245012c3ad1f5013472feced1a41ca (patch)
tree5d7c61d5a0d866d4fd754baf0793db5b858c91fe /dev-util
parentadded more explicit configure options, einfo for tiff issue, stable bumps (diff)
downloadhistorical-d5e3bddd7a245012c3ad1f5013472feced1a41ca.tar.gz
historical-d5e3bddd7a245012c3ad1f5013472feced1a41ca.tar.bz2
historical-d5e3bddd7a245012c3ad1f5013472feced1a41ca.zip
add inherit eutils
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/meld/meld-0.9.1.ebuild6
-rw-r--r--dev-util/perforce-proxy/perforce-proxy-2003.1.ebuild24
-rw-r--r--dev-util/perforce/perforce-2002.2-r1.ebuild19
-rw-r--r--dev-util/perforce/perforce-2002.2.ebuild19
-rw-r--r--dev-util/perforce/perforce-2003.1.ebuild16
-rw-r--r--dev-util/rhide/rhide-1.5-r1.ebuild8
-rw-r--r--dev-util/rhide/rhide-1.5.ebuild8
-rw-r--r--dev-util/rootstrap/rootstrap-0.3.13.ebuild20
-rw-r--r--dev-util/rootstrap/rootstrap-0.3.18.ebuild19
-rw-r--r--dev-util/spe/spe-0.4.2c.ebuild8
10 files changed, 82 insertions, 65 deletions
diff --git a/dev-util/meld/meld-0.9.1.ebuild b/dev-util/meld/meld-0.9.1.ebuild
index 608ca577f381..b0fea59772cd 100644
--- a/dev-util/meld/meld-0.9.1.ebuild
+++ b/dev-util/meld/meld-0.9.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-0.9.1.ebuild,v 1.2 2003/11/25 10:00:42 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-0.9.1.ebuild,v 1.3 2004/04/26 01:32:35 vapier Exp $
-inherit python
+inherit python eutils
DESCRIPTION="A graphical (GNOME 2) diff and merge tool"
HOMEPAGE="http://meld.sourceforge.net/"
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/meld/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~alpha ~sparc"
+KEYWORDS="~x86 ~sparc ~alpha"
IUSE=""
DEPEND=">=dev-lang/python-2.2
diff --git a/dev-util/perforce-proxy/perforce-proxy-2003.1.ebuild b/dev-util/perforce-proxy/perforce-proxy-2003.1.ebuild
index 2e6f19b88830..858c343e870d 100644
--- a/dev-util/perforce-proxy/perforce-proxy-2003.1.ebuild
+++ b/dev-util/perforce-proxy/perforce-proxy-2003.1.ebuild
@@ -1,34 +1,34 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce-proxy/perforce-proxy-2003.1.ebuild,v 1.3 2004/04/26 01:34:26 vapier Exp $
+
+inherit eutils
DESCRIPTION="Proxy daemon for a commercial version control system"
HOMEPAGE="http://www.perforce.com/"
-URI_BASE="ftp://ftp.perforce.com/perforce/r03.1/"
-BIN_BASE="$URI_BASE/bin.linux24x86"
-DOC_BASE="$URI_BASE/doc"
-SRC_URI="${BIN_BASE}/p4p"
+SRC_URI="ftp://ftp.perforce.com/perforce/r03.1/bin.linux24x86/p4p"
+
LICENSE="perforce.pdf"
SLOT="0"
KEYWORDS="x86"
IUSE=""
+RESTRICT="nomirror nostrip"
+
DEPEND="virtual/glibc"
-#RDEPEND=""
+
S=${WORKDIR}
-RESTRICT="nomirror nostrip"
-MY_FILES=$FILESDIR/perforce-proxy-2003.1/
-src_unpack ()
-{
+MY_FILES=${FILESDIR}/perforce-proxy-2003.1/
+
+src_unpack() {
# we have to copy all of the files from $DISTDIR, otherwise we get
# sandbox violations when trying to install
-
for x in p4p ; do
cp ${DISTDIR}/$x .
done
}
-src_install()
-{
+src_install() {
enewuser perforce
enewgroup perforce
diff --git a/dev-util/perforce/perforce-2002.2-r1.ebuild b/dev-util/perforce/perforce-2002.2-r1.ebuild
index 4452e3f84f3a..ada91437eb16 100644
--- a/dev-util/perforce/perforce-2002.2-r1.ebuild
+++ b/dev-util/perforce/perforce-2002.2-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce/perforce-2002.2-r1.ebuild,v 1.2 2004/01/14 00:27:07 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce/perforce-2002.2-r1.ebuild,v 1.3 2004/04/26 01:34:53 vapier Exp $
+
+inherit eutils
DESCRIPTION="Commercial version control system"
HOMEPAGE="http://www.perforce.com/"
@@ -8,18 +10,20 @@ URI_BASE="ftp://ftp.perforce.com/perforce/r02.2/"
BIN_BASE="$URI_BASE/bin.linux24x86"
DOC_BASE="$URI_BASE/doc"
SRC_URI="$BIN_BASE/p4d $BIN_BASE/p4 $BIN_BASE/p4web $BIN_BASE/p4ftpd $BIN_BASE/p4p $DOC_BASE/man/p4.1 $DOC_BASE/man/p4d.1"
+
LICENSE="perforce.pdf"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+RESTRICT="nomirror nostrip"
+
DEPEND="virtual/glibc"
-#RDEPEND=""
+
S=${WORKDIR}
-RESTRICT="nomirror nostrip"
-MY_FILES=$FILESDIR/perforce-2002.2/
-src_unpack ()
-{
+MY_FILES=${FILESDIR}/perforce-2002.2/
+
+src_unpack() {
# we have to copy all of the files from $DISTDIR, otherwise we get
# sandbox violations when trying to install
@@ -28,8 +32,7 @@ src_unpack ()
done
}
-src_install()
-{
+src_install() {
enewuser perforce
enewgroup perforce
diff --git a/dev-util/perforce/perforce-2002.2.ebuild b/dev-util/perforce/perforce-2002.2.ebuild
index c4157d1d5df8..41002763c006 100644
--- a/dev-util/perforce/perforce-2002.2.ebuild
+++ b/dev-util/perforce/perforce-2002.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce/perforce-2002.2.ebuild,v 1.2 2004/01/14 00:27:07 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce/perforce-2002.2.ebuild,v 1.3 2004/04/26 01:36:03 vapier Exp $
+
+inherit eutils
DESCRIPTION="Commercial version control system"
HOMEPAGE="http://www.perforce.com/"
@@ -8,18 +10,20 @@ URI_BASE="ftp://ftp.perforce.com/perforce/r02.2/"
BIN_BASE="$URI_BASE/bin.linux24x86"
DOC_BASE="$URI_BASE/doc"
SRC_URI="$BIN_BASE/p4d $BIN_BASE/p4 $BIN_BASE/p4web $BIN_BASE/p4ftpd $BIN_BASE/p4p $DOC_BASE/man/p4.1 $DOC_BASE/man/p4d.1"
+
LICENSE="perforce.pdf"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+RESTRICT="nomirror nostrip"
+
DEPEND="virtual/glibc"
-#RDEPEND=""
+
S=${WORKDIR}
-RESTRICT="nomirror nostrip"
-MY_FILES=$FILESDIR/perforce-2002.2/
-src_unpack ()
-{
+MY_FILES=${FILESDIR}/perforce-2002.2/
+
+src_unpack() {
# we have to copy all of the files from $DISTDIR, otherwise we get
# sandbox violations when trying to install
@@ -28,8 +32,7 @@ src_unpack ()
done
}
-src_install()
-{
+src_install() {
enewuser perforce
enewgroup perforce
diff --git a/dev-util/perforce/perforce-2003.1.ebuild b/dev-util/perforce/perforce-2003.1.ebuild
index 769409723b38..28a4d1a25e6d 100644
--- a/dev-util/perforce/perforce-2003.1.ebuild
+++ b/dev-util/perforce/perforce-2003.1.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce/perforce-2003.1.ebuild,v 1.3 2004/04/26 01:36:27 vapier Exp $
DESCRIPTION="Daemon for a commercial version control system"
HOMEPAGE="http://www.perforce.com/"
@@ -7,18 +8,20 @@ URI_BASE="ftp://ftp.perforce.com/perforce/r03.1/"
BIN_BASE="$URI_BASE/bin.linux24x86"
DOC_BASE="$URI_BASE/doc"
SRC_URI="${BIN_BASE}/p4d ${BIN_BASE}/p4web ${BIN_BASE}/p4ftpd ${DOC_BASE}/man/p4d.1"
+
LICENSE="perforce.pdf"
SLOT="0"
KEYWORDS="x86"
IUSE=""
+RESTRICT="nomirror nostrip"
+
DEPEND="virtual/glibc"
-#RDEPEND=""
+
S=${WORKDIR}
-RESTRICT="nomirror nostrip"
-MY_FILES=$FILESDIR/perforce-2003.1/
-src_unpack ()
-{
+MY_FILES=${FILESDIR}/perforce-2003.1/
+
+src_unpack() {
# we have to copy all of the files from $DISTDIR, otherwise we get
# sandbox violations when trying to install
@@ -27,8 +30,7 @@ src_unpack ()
done
}
-src_install()
-{
+src_install() {
enewuser perforce
enewgroup perforce
diff --git a/dev-util/rhide/rhide-1.5-r1.ebuild b/dev-util/rhide/rhide-1.5-r1.ebuild
index 79a21a34b8e6..df75363d9795 100644
--- a/dev-util/rhide/rhide-1.5-r1.ebuild
+++ b/dev-util/rhide/rhide-1.5-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rhide/rhide-1.5-r1.ebuild,v 1.9 2004/04/03 21:22:42 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rhide/rhide-1.5-r1.ebuild,v 1.10 2004/04/26 01:37:22 vapier Exp $
+
+inherit eutils
#SNAPSHOT="20020825"
TVISIONVER="2.0.1"
@@ -10,6 +12,7 @@ SETEDIT_S="setedit"
GDBVER="5.3"
DESCRIPTION="console IDE for various languages"
+HOMEPAGE="http://www.rhide.com/"
if [ -z "${SNAPSHOT}" ]
then
S="${WORKDIR}/${P}"
@@ -23,10 +26,9 @@ SRC_URI="${SRC_URI}
mirror://sourceforge/tvision/rhtvision-${TVISIONVER}.src.tar.gz
mirror://sourceforge/setedit/setedit-${SETEDITVER}.tar.gz
mirror://gnu/gdb/gdb-${GDBVER}.tar.bz2"
-HOMEPAGE="http://www.rhide.com/"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
IUSE="X"
diff --git a/dev-util/rhide/rhide-1.5.ebuild b/dev-util/rhide/rhide-1.5.ebuild
index 854301e6acac..07fd5a716696 100644
--- a/dev-util/rhide/rhide-1.5.ebuild
+++ b/dev-util/rhide/rhide-1.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rhide/rhide-1.5.ebuild,v 1.8 2004/04/03 21:22:42 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rhide/rhide-1.5.ebuild,v 1.9 2004/04/26 01:38:33 vapier Exp $
+
+inherit eutils
#SNAPSHOT="20020825"
TVISIONVER="2.0.1"
@@ -10,6 +12,7 @@ SETEDIT_S="setedit"
GDBVER="5.3"
DESCRIPTION="console IDE for various languages"
+HOMEPAGE="http://www.rhide.com/"
if [ -z "${SNAPSHOT}" ]
then
S="${WORKDIR}/${P}"
@@ -23,10 +26,9 @@ SRC_URI="${SRC_URI}
mirror://sourceforge/tvision/rhtvision-${TVISIONVER}.src.tar.gz
mirror://sourceforge/setedit/setedit-${SETEDITVER}.tar.gz
mirror://gnu/gdb/gdb-${GDBVER}.tar.bz2"
-HOMEPAGE="http://www.rhide.com/"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
IUSE="X"
diff --git a/dev-util/rootstrap/rootstrap-0.3.13.ebuild b/dev-util/rootstrap/rootstrap-0.3.13.ebuild
index 198a7919bcd9..1a1639f4acd9 100644
--- a/dev-util/rootstrap/rootstrap-0.3.13.ebuild
+++ b/dev-util/rootstrap/rootstrap-0.3.13.ebuild
@@ -1,23 +1,26 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rootstrap/rootstrap-0.3.13.ebuild,v 1.3 2004/03/02 13:58:51 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rootstrap/rootstrap-0.3.13.ebuild,v 1.4 2004/04/26 01:42:51 vapier Exp $
+
+inherit eutils
DESCRIPTION="A tool for building complete Linux filesystem images"
HOMEPAGE="http://packages.qa.debian.org/rootstrap"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86"
SRC_URI="mirror://debian/pool/main/r/rootstrap/rootstrap_${PV}.orig.tar.gz
mirror://debian/pool/main/r/rootstrap/rootstrap_${PV}-1.diff.gz"
-S=${WORKDIR}/rootstrap-${PV}.orig
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
DEPEND="sys-kernel/usermode-sources
dev-util/debootstrap
app-arch/dpkg
dev-lang/python
app-text/docbook-sgml-utils"
-IUSE=""
+
+S=${WORKDIR}/rootstrap-${PV}.orig
src_unpack() {
unpack rootstrap_${PV}.orig.tar.gz
@@ -27,10 +30,9 @@ src_unpack() {
}
src_compile() {
- emake
+ emake || die
}
src_install() {
- make DESTDIR=${D} install
- dodoc COPYING
+ make DESTDIR=${D} install || die
}
diff --git a/dev-util/rootstrap/rootstrap-0.3.18.ebuild b/dev-util/rootstrap/rootstrap-0.3.18.ebuild
index 60b171791f8b..62fa97429436 100644
--- a/dev-util/rootstrap/rootstrap-0.3.18.ebuild
+++ b/dev-util/rootstrap/rootstrap-0.3.18.ebuild
@@ -1,23 +1,25 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rootstrap/rootstrap-0.3.18.ebuild,v 1.2 2004/04/09 13:09:52 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rootstrap/rootstrap-0.3.18.ebuild,v 1.3 2004/04/26 01:43:38 vapier Exp $
+
+inherit eutils
DESCRIPTION="A tool for building complete Linux filesystem images"
HOMEPAGE="http://packages.qa.debian.org/rootstrap"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86"
SRC_URI="mirror://debian/pool/main/r/rootstrap/rootstrap_${PV}.orig.tar.gz
mirror://debian/pool/main/r/rootstrap/rootstrap_${PV}-1.diff.gz"
-S=${WORKDIR}/rootstrap-${PV}.orig
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
DEPEND="sys-kernel/usermode-sources
dev-util/debootstrap
app-arch/dpkg
dev-lang/python
app-text/docbook-sgml-utils"
-IUSE=""
+S=${WORKDIR}/rootstrap-${PV}.orig
src_unpack() {
unpack rootstrap_${PV}.orig.tar.gz
@@ -27,10 +29,9 @@ src_unpack() {
}
src_compile() {
- emake
+ emake || die
}
src_install() {
- make DESTDIR=${D} install
- dodoc COPYING
+ make DESTDIR=${D} install || die
}
diff --git a/dev-util/spe/spe-0.4.2c.ebuild b/dev-util/spe/spe-0.4.2c.ebuild
index 7105abb754d0..d2c2cc812042 100644
--- a/dev-util/spe/spe-0.4.2c.ebuild
+++ b/dev-util/spe/spe-0.4.2c.ebuild
@@ -1,18 +1,20 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/spe/spe-0.4.2c.ebuild,v 1.1 2003/12/28 00:07:01 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/spe/spe-0.4.2c.ebuild,v 1.2 2004/04/26 01:45:41 vapier Exp $
-inherit distutils
+inherit distutils eutils
MY_P="SPE-0.4.2.c-wx2.4.2.4.-bl2.31"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="Python IDE with Blender support"
HOMEPAGE="http://spe.pycs.net/"
SRC_URI="http://projects.blender.org/download.php/66/${MY_P}.zip"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND=">=dev-lang/python-2.2.3-r1
>=dev-python/wxPython-2.4.2.4"