summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/perforce/perforce-2002.2-r1.ebuild')
-rw-r--r--dev-util/perforce/perforce-2002.2-r1.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/dev-util/perforce/perforce-2002.2-r1.ebuild b/dev-util/perforce/perforce-2002.2-r1.ebuild
index 4452e3f84f3a..ada91437eb16 100644
--- a/dev-util/perforce/perforce-2002.2-r1.ebuild
+++ b/dev-util/perforce/perforce-2002.2-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce/perforce-2002.2-r1.ebuild,v 1.2 2004/01/14 00:27:07 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce/perforce-2002.2-r1.ebuild,v 1.3 2004/04/26 01:34:53 vapier Exp $
+
+inherit eutils
DESCRIPTION="Commercial version control system"
HOMEPAGE="http://www.perforce.com/"
@@ -8,18 +10,20 @@ URI_BASE="ftp://ftp.perforce.com/perforce/r02.2/"
BIN_BASE="$URI_BASE/bin.linux24x86"
DOC_BASE="$URI_BASE/doc"
SRC_URI="$BIN_BASE/p4d $BIN_BASE/p4 $BIN_BASE/p4web $BIN_BASE/p4ftpd $BIN_BASE/p4p $DOC_BASE/man/p4.1 $DOC_BASE/man/p4d.1"
+
LICENSE="perforce.pdf"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+RESTRICT="nomirror nostrip"
+
DEPEND="virtual/glibc"
-#RDEPEND=""
+
S=${WORKDIR}
-RESTRICT="nomirror nostrip"
-MY_FILES=$FILESDIR/perforce-2002.2/
-src_unpack ()
-{
+MY_FILES=${FILESDIR}/perforce-2002.2/
+
+src_unpack() {
# we have to copy all of the files from $DISTDIR, otherwise we get
# sandbox violations when trying to install
@@ -28,8 +32,7 @@ src_unpack ()
done
}
-src_install()
-{
+src_install() {
enewuser perforce
enewgroup perforce