summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-12-29 20:29:05 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-12-29 20:31:09 +0100
commit3f74b59c3c9aaecadddf9625f1e38086565f7bc6 (patch)
treed9be0bbac68fe2f28de8d0c8ed1616a4217dbae8 /sys-libs
parentdev-util/idea-community: Version bump, remove old (diff)
downloadgentoo-3f74b59c3c9aaecadddf9625f1e38086565f7bc6.tar.gz
gentoo-3f74b59c3c9aaecadddf9625f1e38086565f7bc6.tar.bz2
gentoo-3f74b59c3c9aaecadddf9625f1e38086565f7bc6.zip
sys-libs/glibc: Bugfix, against false errors in last minute run test
If there is a ld.so in a subdirectory of the libdir, it might have been picked first ... Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.34-r4.ebuild2
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.34-r4.ebuild b/sys-libs/glibc/glibc-2.34-r4.ebuild
index 4346f19004c8..88f72ad1d7db 100644
--- a/sys-libs/glibc/glibc-2.34-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.34-r4.ebuild
@@ -1546,7 +1546,7 @@ glibc_sanity_check() {
# first let's find the actual dynamic linker here
# symlinks may point to the wrong abi
- local newldso=$(find . -name 'ld*so.?' -type f -print -quit)
+ local newldso=$(find . -maxdepth 1 -name 'ld*so.?' -type f -print -quit)
einfo Last-minute run tests with ${newldso} in /$(get_libdir) ...
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 2cb4bf86808c..19d0bf001397 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1539,7 +1539,7 @@ glibc_sanity_check() {
# first let's find the actual dynamic linker here
# symlinks may point to the wrong abi
- local newldso=$(find . -name 'ld*so.?' -type f -print -quit)
+ local newldso=$(find . -maxdepth 1 -name 'ld*so.?' -type f -print -quit)
einfo Last-minute run tests with ${newldso} in /$(get_libdir) ...