From 3f74b59c3c9aaecadddf9625f1e38086565f7bc6 Mon Sep 17 00:00:00 2001
From: "Andreas K. Hüttel" <dilfridge@gentoo.org>
Date: Wed, 29 Dec 2021 20:29:05 +0100
Subject: sys-libs/glibc: Bugfix, against false errors in last minute run test

If there is a ld.so in a subdirectory of the libdir, it might have been
picked first ...

Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
---
 sys-libs/glibc/glibc-2.34-r4.ebuild | 2 +-
 sys-libs/glibc/glibc-9999.ebuild    | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

(limited to 'sys-libs')

diff --git a/sys-libs/glibc/glibc-2.34-r4.ebuild b/sys-libs/glibc/glibc-2.34-r4.ebuild
index 4346f19004c8..88f72ad1d7db 100644
--- a/sys-libs/glibc/glibc-2.34-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.34-r4.ebuild
@@ -1546,7 +1546,7 @@ glibc_sanity_check() {
 
 	# first let's find the actual dynamic linker here
 	# symlinks may point to the wrong abi
-	local newldso=$(find . -name 'ld*so.?' -type f -print -quit)
+	local newldso=$(find . -maxdepth 1 -name 'ld*so.?' -type f -print -quit)
 
 	einfo Last-minute run tests with ${newldso} in /$(get_libdir) ...
 
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 2cb4bf86808c..19d0bf001397 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1539,7 +1539,7 @@ glibc_sanity_check() {
 
 	# first let's find the actual dynamic linker here
 	# symlinks may point to the wrong abi
-	local newldso=$(find . -name 'ld*so.?' -type f -print -quit)
+	local newldso=$(find . -maxdepth 1 -name 'ld*so.?' -type f -print -quit)
 
 	einfo Last-minute run tests with ${newldso} in /$(get_libdir) ...
 
-- 
cgit v1.2.3-65-gdbad