summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-05-29 12:02:34 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-01 16:43:05 -0400
commit07401ce132591663d8c32b7ecaa8a2d7d0a6ce7b (patch)
tree44f1065b5b4a3e3caa1ddb16ddfd470f3f4d285b /sci-libs/volk
parentdev-python/pybind11: bump (diff)
downloadgentoo-07401ce132591663d8c32b7ecaa8a2d7d0a6ce7b.tar.gz
gentoo-07401ce132591663d8c32b7ecaa8a2d7d0a6ce7b.tar.bz2
gentoo-07401ce132591663d8c32b7ecaa8a2d7d0a6ce7b.zip
sci-libs/volk: initial ebuild
single test failure reported upstream https://github.com/gnuradio/volk/issues/382 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'sci-libs/volk')
-rw-r--r--sci-libs/volk/Manifest1
-rw-r--r--sci-libs/volk/metadata.xml8
-rw-r--r--sci-libs/volk/volk-2.3.0.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/volk/Manifest b/sci-libs/volk/Manifest
new file mode 100644
index 000000000000..76da000db8d5
--- /dev/null
+++ b/sci-libs/volk/Manifest
@@ -0,0 +1 @@
+DIST volk-2.3.0.tar.gz 344763 BLAKE2B 0f0e0cb7e6cd28086802c1618685ec30dedf5cdf67bef7ed09f3a7482f84d6e7972f4b22c096676bdef34c66c60d936ca8ab300cd4da07f6714cface1c2846ed SHA512 9e3b405b7be46b4f5ff61a4d42fa9013fc55169bc18c9cf9253e446fe23fd12dc0356adb9aa176e33dfa4cc478e4b9226bee906a2d89ef83bac3b28f52816382
diff --git a/sci-libs/volk/metadata.xml b/sci-libs/volk/metadata.xml
new file mode 100644
index 000000000000..2b9b4266ca5b
--- /dev/null
+++ b/sci-libs/volk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-libs/volk/volk-2.3.0.ebuild b/sci-libs/volk/volk-2.3.0.ebuild
new file mode 100644
index 000000000000..6314b75fc523
--- /dev/null
+++ b/sci-libs/volk/volk-2.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="vector optimized library of kernels"
+HOMEPAGE="http://libvolk.org"
+SRC_URI="https://github.com/gnuradio/volk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+orc"
+
+RDEPEND="dev-libs/boost"
+DEPEND="${RDEPEND}
+ !net-wireless/gnuradio[-system-volk]
+ dev-python/mako
+ dev-python/six
+ dev-lang/orc"
+
+CMAKE_BUILD_TYPE=Release
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ORC=$(usex orc)
+ )
+ cmake-utils_src_configure
+}