summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/volk/volk-2.3.0.ebuild')
-rw-r--r--sci-libs/volk/volk-2.3.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-libs/volk/volk-2.3.0.ebuild b/sci-libs/volk/volk-2.3.0.ebuild
new file mode 100644
index 000000000000..6314b75fc523
--- /dev/null
+++ b/sci-libs/volk/volk-2.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="vector optimized library of kernels"
+HOMEPAGE="http://libvolk.org"
+SRC_URI="https://github.com/gnuradio/volk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+orc"
+
+RDEPEND="dev-libs/boost"
+DEPEND="${RDEPEND}
+ !net-wireless/gnuradio[-system-volk]
+ dev-python/mako
+ dev-python/six
+ dev-lang/orc"
+
+CMAKE_BUILD_TYPE=Release
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ORC=$(usex orc)
+ )
+ cmake-utils_src_configure
+}