summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-26 20:27:00 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-26 20:27:40 -0700
commit8e34d7323f299be727450ce19abad08e27bedda6 (patch)
tree5a6528aa83bc2ef6ca36199a73575995013b7482 /gnome-base/librsvg
parentapp-text/lesspipe: add 2.05 (diff)
downloadgentoo-8e34d7323f299be727450ce19abad08e27bedda6.tar.gz
gentoo-8e34d7323f299be727450ce19abad08e27bedda6.tar.bz2
gentoo-8e34d7323f299be727450ce19abad08e27bedda6.zip
gnome-base/librsvg: Version bump to 2.54.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base/librsvg')
-rw-r--r--gnome-base/librsvg/Manifest1
-rw-r--r--gnome-base/librsvg/files/librsvg-2.54.1-build-Add-enable-gtk-doc-flag.patch62
-rw-r--r--gnome-base/librsvg/librsvg-2.54.1.ebuild113
3 files changed, 176 insertions, 0 deletions
diff --git a/gnome-base/librsvg/Manifest b/gnome-base/librsvg/Manifest
index a98cc44df5bb..52fc031b8e2f 100644
--- a/gnome-base/librsvg/Manifest
+++ b/gnome-base/librsvg/Manifest
@@ -2,3 +2,4 @@ DIST librsvg-2.40.21.tar.xz 1655860 BLAKE2B a3fd7915d39984057e860da90115d9d95cef
DIST librsvg-2.52.6.tar.xz 23662708 BLAKE2B 21108297aa4f87a852d0decb9cc7b8a5cdb546e00075d16f0f86502752adc176a67b56607eb90b034ca4e2dddbf8f82a3d81727496a5ae1a2b94715cdbbd87ac SHA512 be4830fb34c4859bdbe0c86da7b5de0807f28bb63fc124b4405ca8f9ef6ee45add77b4c43b9031d00157870eceb458df30cf5ee25e73d3894797d622b465f38d
DIST librsvg-2.52.7.tar.xz 23709632 BLAKE2B 4eb83d71b77b851c408ddba711fe39ed23863aa6466634020a19ffc30e00c12f7dea81f11fdc09eb53c0c72efb35adc4528568b3c27e5dc0e886426d145d347f SHA512 15c075d696ebba35555f93456be088e6398da5b7992119edc78f1ee1d376a70425248e36b138dc86234aec13cb139fded11d6d74523c44f9a49eb19c2151fcb7
DIST librsvg-2.54.0.tar.xz 23489972 BLAKE2B 04fcbb688b18e98dcbef81e84106a99280d45f242152a355ac6f202410c13b289b281bd10f9e77854997362b7d3e88832d3274d7d63ace8adc05613da99e2aab SHA512 3357ca8cf7537fe2792ee2d9a1719622656f3e1d7f30da062799a4b3ca8788cc07333a00e1c9da53a53da2b67a2aa5895a4c8fce35003da659fb7f98048b68eb
+DIST librsvg-2.54.1.tar.xz 28181768 BLAKE2B 86e1cf01febce55acadc9b05f5e08fda69423ab267ab8330bbf892d63f475d5ddd163099346f3cf1e63bf2807d847440cf48d8b24f3c32b3ab14a35c0c54d96e SHA512 d1ea8a49988fed1d7a2ba21540a6c10084cd78f8b6db3534882d086a09f3a0d96ec80c59b3744a6eeef8ae511f0b0152eaf18cc9a134f4b871a993418cae09a6
diff --git a/gnome-base/librsvg/files/librsvg-2.54.1-build-Add-enable-gtk-doc-flag.patch b/gnome-base/librsvg/files/librsvg-2.54.1-build-Add-enable-gtk-doc-flag.patch
new file mode 100644
index 000000000000..ee5c3bce0a5c
--- /dev/null
+++ b/gnome-base/librsvg/files/librsvg-2.54.1-build-Add-enable-gtk-doc-flag.patch
@@ -0,0 +1,62 @@
+https://gitlab.gnome.org/GNOME/librsvg/-/merge_requests/692
+
+From 1c53068cbcfccb9c663dea2d1a61c8d7b24d317a Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Tue, 26 Apr 2022 15:01:55 -0700
+Subject: [PATCH] build: Add --enable-gtk-doc flag
+
+gtk-doc documentation relies on introspection, and introspection doesn't
+cross compile well, so it's nice to be able to disable documentation.
+---
+ Makefile.am | 2 +-
+ configure.ac | 19 ++++++++++++++-----
+ 2 files changed, 15 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 83e73c38..1e1ce856 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,4 +1,4 @@
+-if HAVE_GI_DOCGEN
++if ENABLE_GTK_DOC
+ RSVG_DOC = doc
+ endif
+
+diff --git a/configure.ac b/configure.ac
+index 9abc587e..6cced25c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -123,11 +123,19 @@ AM_CONDITIONAL(HAVE_RST2MAN, [test "x$RST2MAN" != "xno"])
+
+ dnl Gi-docgen
+
+-AC_CHECK_TOOL(GI_DOCGEN, [gi-docgen], [no])
+-AS_IF(test x$GI_DOCGEN = xno,
+- AC_MSG_WARN([gi-docgen not found - not building docs])
+-)
+-AM_CONDITIONAL(HAVE_GI_DOCGEN, [test "x$GI_DOCGEN" != "xno"])
++AC_ARG_ENABLE([gtk-doc],
++ [AS_HELP_STRING([--disable-gtk-doc],[Disable building documentation (requires introspection)])],
++ [enable_gtk_doc=$enableval],[enable_gtk_doc=auto])
++
++AS_IF([test "x$enable_gtk_doc" != xno],
++ [AC_CHECK_TOOL(GI_DOCGEN, [gi-docgen], [no])
++ AS_IF([test "x$GI_DOCGEN" = no],
++ [AS_CASE(["$enable_gtk_doc"],
++ [yes], [AC_MSG_ERROR([gi-docgen not found - cannot build docs])],
++ [auto], [AC_MSG_WARN([gi-docgen not found - not building docs])])
++ enable_gtk_doc=no]
++ [enable_gtk_doc=yes])])
++AM_CONDITIONAL(ENABLE_GTK_DOC, [test "x$enable_gtk_doc" = xyes])
+
+ dnl ===========================================================================
+
+@@ -359,4 +367,5 @@ librsvg-$VERSION
+ Build introspectable bindings: ${found_introspection}
+ Build Vala bindings: ${enable_vala}
+ Build GdkPixbuf loader: ${enable_pixbuf_loader}
++ Build developer documentation: ${enable_gtk_doc}
+ "
+--
+2.35.1
+
diff --git a/gnome-base/librsvg/librsvg-2.54.1.ebuild b/gnome-base/librsvg/librsvg-2.54.1.ebuild
new file mode 100644
index 000000000000..656e02c638ae
--- /dev/null
+++ b/gnome-base/librsvg/librsvg-2.54.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_EAUTORECONF=yes # for patching configure.ac
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome2 multilib-minimal python-any-r1 rust-toolchain vala
+
+DESCRIPTION="Scalable Vector Graphics (SVG) rendering library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibRsvg https://gitlab.gnome.org/GNOME/librsvg"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="gtk-doc +introspection +vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+RESTRICT="test" # Lots of issues on 32bit builds, 64bit build seems to get into an infinite compilation sometimes, etc.
+
+RDEPEND="
+ >=x11-libs/cairo-1.16.0[glib,svg,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.9:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.20:2[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.50.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.0.0:=[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.48.11[${MULTILIB_USEDEP}]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+"
+DEPEND="${RDEPEND}
+ >=virtual/rust-1.56[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]')
+ gtk-doc? ( dev-util/gi-docgen )
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+
+ dev-libs/gobject-introspection-common
+ dev-libs/vala-common
+"
+# dev-libs/gobject-introspection-common, dev-libs/vala-common needed by eautoreconf
+
+QA_FLAGS_IGNORED="
+ usr/bin/rsvg-convert
+ usr/lib.*/librsvg.*
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build-Add-enable-gtk-doc-flag.patch
+)
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --disable-static
+ --disable-debug
+ $(multilib_native_use_enable gtk-doc)
+ $(multilib_native_use_enable introspection)
+ $(multilib_native_use_enable vala)
+ --enable-pixbuf-loader
+ )
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ # Set the rust target, which can differ from CHOST
+ RUST_TARGET="$(rust_abi)"
+ # RUST_TARGET is only honored if cross_compiling, but non-native ABIs aren't cross as
+ # far as C parts and configure auto-detection are concerned as CHOST equals CBUILD
+ cross_compiling=yes
+ )
+ fi
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure "${myconf[@]}"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_compile() {
+ gnome2_src_compile
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PF}/Rsvg-2.0 "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}
+
+pkg_postinst() {
+ multilib_foreach_abi gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ multilib_foreach_abi gnome2_pkg_postrm
+}