summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:33:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:33:21 +0200
commite7170abbd837dbf0c986d8ab7ce8e31fa38f8f44 (patch)
tree01733839d1312669453b980241bed0f968f13127 /dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
parentdev-ros/rqt_nav_view: Initial import. Ebuild by me. (diff)
downloadgentoo-e7170abbd837dbf0c986d8ab7ce8e31fa38f8f44.tar.gz
gentoo-e7170abbd837dbf0c986d8ab7ce8e31fa38f8f44.tar.bz2
gentoo-e7170abbd837dbf0c986d8ab7ce8e31fa38f8f44.zip
dev-ros/rqt_pose_view: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild')
-rw-r--r--dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild b/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
new file mode 100644
index 000000000000..a4afb74d8d61
--- /dev/null
+++ b/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing 3D poses"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-python/PyQt4[opengl,${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"