summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-17 15:02:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-17 15:35:18 +0200
commit55537978d1d30458d1a2ff900491137993c61767 (patch)
treec67d3623ea679b437f5595f8281619a06e211603 /dev-python
parentdev-python/django-filter: Bump to 23.3 (diff)
downloadgentoo-55537978d1d30458d1a2ff900491137993c61767.tar.gz
gentoo-55537978d1d30458d1a2ff900491137993c61767.tar.bz2
gentoo-55537978d1d30458d1a2ff900491137993c61767.zip
dev-python/djangorestframework: Remove dev-python/core* deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.14.0.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
index b31831ebf043..4a442c77fc6d 100644
--- a/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
+++ b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
@@ -10,7 +10,11 @@ inherit distutils-r1
MY_P=django-rest-framework-${PV}
DESCRIPTION="Web APIs with django made easy"
-HOMEPAGE="https://www.django-rest-framework.org/"
+HOMEPAGE="
+ https://www.django-rest-framework.org/
+ https://github.com/encode/django-rest-framework/
+ https://pypi.org/project/djangorestframework/
+"
SRC_URI="
https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
@@ -27,8 +31,6 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/coreapi[${PYTHON_USEDEP}]
- dev-python/coreschema[${PYTHON_USEDEP}]
dev-python/pytest-django[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
)
@@ -38,4 +40,9 @@ distutils_enable_tests pytest
EPYTEST_DESELECT=(
tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+
+ # require coreapi (but not skipped properly)
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_default_schema_with_custom_title_url_and_desc
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_openapi_json_schema
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_renders_corejson_schema
)