summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-17 14:56:49 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-17 15:35:17 +0200
commitb5a8a41c015eb53e0c92cc00abcb45245ad76b9b (patch)
treee773de5e7a6a999c2c60dc00036accfa995461d6 /dev-python
parentdev-python/patiencediff: Bump to 0.2.14 (diff)
downloadgentoo-b5a8a41c015eb53e0c92cc00abcb45245ad76b9b.tar.gz
gentoo-b5a8a41c015eb53e0c92cc00abcb45245ad76b9b.tar.bz2
gentoo-b5a8a41c015eb53e0c92cc00abcb45245ad76b9b.zip
dev-python/django-filter: Bump to 23.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-filter/Manifest1
-rw-r--r--dev-python/django-filter/django-filter-23.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-filter/Manifest b/dev-python/django-filter/Manifest
index a85859cefd12..a0a79e88f0a3 100644
--- a/dev-python/django-filter/Manifest
+++ b/dev-python/django-filter/Manifest
@@ -1 +1,2 @@
DIST django-filter-23.1.gh.tar.gz 135407 BLAKE2B a23b7c6ae4692bd991aee4c0dfc4beb699ffbaec4e831dd3d13cb7b76f6acf4ba015c73bc7c9be21f6d95dfe17691f43baeda1f04b7e8757ced315c80d111d72 SHA512 c8437c3806e9d0e05bbbb938d225abe05da33103c729ccdb97dd47b7482178530a3fed5efba22458440530bd71cc9a171bae8fa81c2a67a50e5c6f34f2c300a2
+DIST django-filter-23.3.gh.tar.gz 137495 BLAKE2B 70049e744ec87a1dab9680144093684d3d23dd338a9b2d697de302b45e65bcd6f93c03c55ad5386ba1a7187e7ff5d1c43904f19cb17652ef6644b47a0f23101c SHA512 1da3f9bb1988d0b89d25f4101c26f4102d38e4717cdbd8d0cd4ae03a97658bfcc050afd3468ef6d0e33dc6533c7679f1906ddaccba8e7096a4bd570282a93c0a
diff --git a/dev-python/django-filter/django-filter-23.3.ebuild b/dev-python/django-filter/django-filter-23.3.ebuild
new file mode 100644
index 000000000000..a3c5da1ca1c3
--- /dev/null
+++ b/dev-python/django-filter/django-filter-23.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django app allowing declarative dynamic QuerySet filtering from URL parameters"
+HOMEPAGE="
+ https://github.com/carltongibson/django-filter/
+ https://pypi.org/project/django-filter/
+"
+SRC_URI="
+ https://github.com/carltongibson/django-filter/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ !!dev-python/coreapi
+ )
+"
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings
+ "${EPYTHON}" -m django test -v 2 || die
+}