summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pytables
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/Manifest2
-rw-r--r--dev-python/pytables/files/pytables-3.1.1-blosc.patch16
-rw-r--r--dev-python/pytables/files/pytables-3.1.1-cython-backport.patch65
-rw-r--r--dev-python/pytables/files/pytables-3.1.1-numpy19-backport.patch51
-rw-r--r--dev-python/pytables/files/pytables-3.2.0-blosc.patch16
-rw-r--r--dev-python/pytables/metadata.xml17
-rw-r--r--dev-python/pytables/pytables-3.1.1-r2.ebuild75
-rw-r--r--dev-python/pytables/pytables-3.2.0.ebuild73
8 files changed, 315 insertions, 0 deletions
diff --git a/dev-python/pytables/Manifest b/dev-python/pytables/Manifest
new file mode 100644
index 000000000000..418fb38acd5d
--- /dev/null
+++ b/dev-python/pytables/Manifest
@@ -0,0 +1,2 @@
+DIST tables-3.1.1.tar.gz 6715786 SHA256 39b9036376f1185599771c19276f13b5b9119d98f9108f58595745ded3fe2da3 SHA512 b5b2052dd81c4748c5e26c1f61f9f92891f48335b0a553f7602ab11c9029dd673d27b91e24cac0da21a81df0c26dbcd9a438214fa58af1ae831c5f04dfa212a6 WHIRLPOOL 86fd6dc9e12503fdbd23013b75f33a41eadbbac0e6dd5ac9a91476d073195077fc6b3d5ad24b1dd4b4c18ae7ed8abc8ea1708262e52240f4c2c3b1153f8c9e91
+DIST tables-3.2.0.tar.gz 7039718 SHA256 60980e44676bfe463cdd2582ecdacc0b0763b259477015e866f8af72b4cdba44 SHA512 6ef7925bafbec04a3f581d13e9cc266b9b68b11dce27cf28c501dbbc538d74ddcfa15cbe97fa69fb793911cc6dbf3112f503b29c6e4e3e7631a6761cc1303253 WHIRLPOOL 412ada055b81fd7409b67288bc2bcf9ed527c9c42dbdd75c52ce7287f53ed12322b8b4423c9fab0aba98e0f12a8764a45316104567c193b469a84fdda3cbfc30
diff --git a/dev-python/pytables/files/pytables-3.1.1-blosc.patch b/dev-python/pytables/files/pytables-3.1.1-blosc.patch
new file mode 100644
index 000000000000..3a4ba18e5e73
--- /dev/null
+++ b/dev-python/pytables/files/pytables-3.1.1-blosc.patch
@@ -0,0 +1,16 @@
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 2c0c126..1448eb1 100755
+--- a/setup.py
++++ b/setup.py
+@@ -768,7 +768,7 @@ if 'BLOSC' not in optional_libs:
+ print("Setting compiler flag '-msse2'")
+ CFLAGS.append("-msse2")
+ else:
+- ADDLIBS += ['blosc']
++ ADDLIBS += ['blosc', 'blosc_filter']
+
+
+ utilsExtension_libs = LIBS + ADDLIBS
diff --git a/dev-python/pytables/files/pytables-3.1.1-cython-backport.patch b/dev-python/pytables/files/pytables-3.1.1-cython-backport.patch
new file mode 100644
index 000000000000..7db41d2e1a62
--- /dev/null
+++ b/dev-python/pytables/files/pytables-3.1.1-cython-backport.patch
@@ -0,0 +1,65 @@
+ setup.py | 13 +++++++------
+ tables/req_versions.py | 2 +-
+ 2 files changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 0f2f3f7..52cda49 100755
+--- a/setup.py
++++ b/setup.py
+@@ -25,6 +25,7 @@ from distutils.core import Extension
+ from distutils.dep_util import newer
+ from distutils.util import convert_path
+ from distutils.ccompiler import new_compiler
++from distutils.version import LooseVersion
+
+ cmdclass = {}
+ setuptools_kwargs = {}
+@@ -106,7 +107,7 @@ def check_import(pkgname, pkgver):
+ "You need %(pkgname)s %(pkgver)s or greater to run PyTables!"
+ % {'pkgname': pkgname, 'pkgver': pkgver})
+ else:
+- if mod.__version__ < pkgver:
++ if mod.__version__ < LooseVersion(pkgver):
+ exit_with_error(
+ "You need %(pkgname)s %(pkgver)s or greater to run PyTables!"
+ % {'pkgname': pkgname, 'pkgver': pkgver})
+@@ -122,21 +123,21 @@ if not has_setuptools:
+
+ # Check if Cython is installed or not (requisite)
+ try:
++ from Cython import __version__ as cython_version
+ from Cython.Distutils import build_ext
+- from Cython.Compiler.Main import Version
+ cmdclass['build_ext'] = build_ext
+ except ImportError:
+ exit_with_error(
+ "You need %(pkgname)s %(pkgver)s or greater to compile PyTables!"
+ % {'pkgname': 'Cython', 'pkgver': min_cython_version})
+
+-if Version.version < min_cython_version:
++if LooseVersion(cython_version) < min_cython_version:
+ exit_with_error(
+- "At least Cython %s is needed so as to generate extensions!"
+- % (min_cython_version))
++ "You need %(pkgname)s %(pkgver)s or greater to run PyTables!"
++ % {'pkgname': 'Cython', 'pkgver': min_cython_version})
+ else:
+ print("* Found %(pkgname)s %(pkgver)s package installed."
+- % {'pkgname': 'Cython', 'pkgver': Version.version})
++ % {'pkgname': 'Cython', 'pkgver': cython_version})
+
+ VERSION = open('VERSION').read().strip()
+
+diff --git a/tables/req_versions.py b/tables/req_versions.py
+index 2c9ca01..bd498c3 100644
+--- a/tables/req_versions.py
++++ b/tables/req_versions.py
+@@ -17,7 +17,7 @@
+ # Minimum recommended versions for mandatory packages
+ min_numpy_version = '1.4.1'
+ min_numexpr_version = '2.0.0'
+-min_cython_version = '0.13'
++min_cython_version = '0.14'
+
+ # The THG team has decided to fix an API inconsistency in the definition
+ # of the H5Z_class_t structure in version 1.8.3
diff --git a/dev-python/pytables/files/pytables-3.1.1-numpy19-backport.patch b/dev-python/pytables/files/pytables-3.1.1-numpy19-backport.patch
new file mode 100644
index 000000000000..c2f0c2280f01
--- /dev/null
+++ b/dev-python/pytables/files/pytables-3.1.1-numpy19-backport.patch
@@ -0,0 +1,51 @@
+From 854d5798ca9fd78c00e18710de2e93202f675f3e Mon Sep 17 00:00:00 2001
+From: Antonio Valentino <antonio.valentino@tiscali.it>
+Date: Sun, 6 Jul 2014 21:21:39 +0200
+Subject: [PATCH] Fix a compatibility problem with numpy 1.9 (close: #362)
+
+---
+ RELEASE_NOTES.txt | 6 ++++++
+ tables/table.py | 6 +++++-
+ 2 files changed, 11 insertions(+), 1 deletion(-)
+
+diff --git a/RELEASE_NOTES.txt b/RELEASE_NOTES.txt
+index f219eb3..1da20e2 100644
+--- a/RELEASE_NOTES.txt
++++ b/RELEASE_NOTES.txt
+@@ -19,6 +19,12 @@ Improvements
+ requiring strict access alignment.
+
+
++Bugs fixed
++----------
++
++- Fixed compatibitily problems with numpy 1.9 (closes :issue:`362`)
++
++
+ Changes from 3.1.0 to 3.1.1
+ ===========================
+
+diff --git a/tables/table.py b/tables/table.py
+index 235f599..ffe8fd6 100644
+--- a/tables/table.py
++++ b/tables/table.py
+@@ -3406,6 +3406,10 @@ def _getindex(self):
+ associated with this column (None if the column is not
+ indexed).""")
+
++ @lazyattr
++ def _itemtype(self):
++ return self.descr._v_dtypes[self.name]
++
+ def _getshape(self):
+ return (self.table.nrows,) + self.descr._v_dtypes[self.name].shape
+
+@@ -3529,7 +3533,7 @@ def __iter__(self):
+ table = self.table
+ itemsize = self.dtype.itemsize
+ nrowsinbuf = table._v_file.params['IO_BUFFER_SIZE'] // itemsize
+- buf = numpy.empty((nrowsinbuf, ), self.dtype)
++ buf = numpy.empty((nrowsinbuf, ), self._itemtype)
+ max_row = len(self)
+ for start_row in xrange(0, len(self), nrowsinbuf):
+ end_row = min(start_row + nrowsinbuf, max_row)
diff --git a/dev-python/pytables/files/pytables-3.2.0-blosc.patch b/dev-python/pytables/files/pytables-3.2.0-blosc.patch
new file mode 100644
index 000000000000..24c58c1a921c
--- /dev/null
+++ b/dev-python/pytables/files/pytables-3.2.0-blosc.patch
@@ -0,0 +1,16 @@
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 2c0c126..1448eb1 100755
+--- a/setup.py
++++ b/setup.py
+@@ -768,7 +768,7 @@ if 'BLOSC' not in optional_libs:
+ CFLAGS.append(ff)
+ break
+ else:
+- ADDLIBS += ['blosc']
++ ADDLIBS += ['blosc', 'blosc_filter']
+
+
+ utilsExtension_libs = LIBS + ADDLIBS
diff --git a/dev-python/pytables/metadata.xml b/dev-python/pytables/metadata.xml
new file mode 100644
index 000000000000..9a0c6541eff2
--- /dev/null
+++ b/dev-python/pytables/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ PyTables is a hierarchical database package designed to efficently
+ manage very large amounts of data. PyTables is built on top of the
+ HDF5 library and the NumPy package. It features an object-oriented
+ interface that, combined with natural naming and C-code generated
+ from Pyrex sources, makes it a fast, yet extremely easy to use tool
+ for interactively save and retrieve large amounts of data.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">tables</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytables/pytables-3.1.1-r2.ebuild b/dev-python/pytables/pytables-3.1.1-r2.ebuild
new file mode 100644
index 000000000000..e8fb46b57ea5
--- /dev/null
+++ b/dev-python/pytables/pytables-3.1.1-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+MY_PN=tables
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Hierarchical datasets for Python"
+HOMEPAGE="http://www.pytables.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD"
+IUSE="doc examples"
+
+RDEPEND="
+ app-arch/bzip2:0=
+ dev-libs/c-blosc:0=[hdf5]
+ dev-libs/lzo:2=
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ sci-libs/hdf5:0="
+DEPEND="${RDEPEND}
+ >=dev-python/cython-0.14[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( ANNOUNCE.txt RELEASE_NOTES.txt THANKS )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cython-backport.patch
+ "${FILESDIR}"/${P}-numpy19-backport.patch
+ "${FILESDIR}"/${P}-blosc.patch
+ )
+
+python_prepare_all() {
+ export HDF5_DIR="${EPREFIX}"/usr
+ sed \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ -e 's:"c-blosc/hdf5/blosc_filter.c"::g' \
+ -i setup.py || die
+ rm -r c-blosc/{blosc,hdf5,internal-complibs} || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib* || die
+ ${EPYTHON} tables/tests/test_all.py || die
+}
+
+python_install_all() {
+ if use doc; then
+ HTML_DOCS=( doc/html/. )
+ DOCS+=( doc/scripts )
+ fi
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ doins -r contrib
+ fi
+}
diff --git a/dev-python/pytables/pytables-3.2.0.ebuild b/dev-python/pytables/pytables-3.2.0.ebuild
new file mode 100644
index 000000000000..e1a0c772f5af
--- /dev/null
+++ b/dev-python/pytables/pytables-3.2.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+MY_PN=tables
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Hierarchical datasets for Python"
+HOMEPAGE="http://www.pytables.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD"
+IUSE="doc examples"
+
+RDEPEND="
+ app-arch/bzip2:0=
+ dev-libs/c-blosc:0=[hdf5]
+ dev-libs/lzo:2=
+ >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/numexpr-2.4[${PYTHON_USEDEP}]
+ >=sci-libs/hdf5-1.8.4:0="
+DEPEND="${RDEPEND}
+ >=dev-python/cython-0.14[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( ANNOUNCE.txt RELEASE_NOTES.txt THANKS )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-blosc.patch
+ )
+
+python_prepare_all() {
+ export HDF5_DIR="${EPREFIX}"/usr
+ sed \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ -e 's:"c-blosc/hdf5/blosc_filter.c"::g' \
+ -i setup.py || die
+ rm -r c-blosc/{blosc,hdf5,internal-complibs} || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib* || die
+ ${EPYTHON} tables/tests/test_all.py || die
+}
+
+python_install_all() {
+ if use doc; then
+ HTML_DOCS=( doc/html/. )
+ DOCS+=( doc/scripts )
+ fi
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ doins -r contrib
+ fi
+}