summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-14 15:27:18 +0200
committerZac Medico <zmedico@gentoo.org>2020-10-14 18:44:02 -0700
commit17b538a961e915abe54b87abbe821c5adee90c2f (patch)
tree53fefe0c5bbfec688960bc458655c4011cd03ac6 /dev-python/pyghmi
parentdev-python/ntplib: correct DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-17b538a961e915abe54b87abbe821c5adee90c2f.tar.gz
gentoo-17b538a961e915abe54b87abbe821c5adee90c2f.tar.bz2
gentoo-17b538a961e915abe54b87abbe821c5adee90c2f.zip
dev-python/pyghmi: correct DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/748528 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.5.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/pyghmi/pyghmi-1.5.5.ebuild b/dev-python/pyghmi/pyghmi-1.5.5.ebuild
index a2085f3c7d12..d9f450e16060 100644
--- a/dev-python/pyghmi/pyghmi-1.5.5.ebuild
+++ b/dev-python/pyghmi/pyghmi-1.5.5.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -21,7 +23,6 @@ RDEPEND=">=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
>=dev-python/coverage-4.0[${PYTHON_USEDEP}]
>=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]