summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-05-31 15:38:56 +0800
committerWANG Xuerui <xen0n@gentoo.org>2023-07-20 17:48:26 +0800
commit35c325dde79c4383fe1f7dce7e607c064d8b84ee (patch)
tree1af19c7eff529547bd24d08b8047cfac11f89a44 /dev-lang/rust/rust-1.70.0.ebuild
parentrust-toolchain.eclass: add support for mips64el platforms (diff)
downloadgentoo-35c325dde79c4383fe1f7dce7e607c064d8b84ee.tar.gz
gentoo-35c325dde79c4383fe1f7dce7e607c064d8b84ee.tar.bz2
gentoo-35c325dde79c4383fe1f7dce7e607c064d8b84ee.zip
rust-toolchain.eclass: qualify applicable rust_arch_uris with ABI and endianness
For less downloading client-side, as it is likely that only one package in each covered group would work on a given system. See: https://github.com/gentoo/gentoo/pull/31241 Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Diffstat (limited to 'dev-lang/rust/rust-1.70.0.ebuild')
-rw-r--r--dev-lang/rust/rust-1.70.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-lang/rust/rust-1.70.0.ebuild b/dev-lang/rust/rust-1.70.0.ebuild
index 1f659bb445d7..6a3217a13741 100644
--- a/dev-lang/rust/rust-1.70.0.ebuild
+++ b/dev-lang/rust/rust-1.70.0.ebuild
@@ -41,7 +41,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/(-)?}
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
-IUSE="clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind +lto miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
+IUSE="big-endian clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind +lto miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
# Please keep the LLVM dependency block separate. Since LLVM is slotted,
# we need to *really* make sure we're not pulling more than one slot