summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-05-31 15:38:56 +0800
committerWANG Xuerui <xen0n@gentoo.org>2023-07-20 17:48:26 +0800
commit35c325dde79c4383fe1f7dce7e607c064d8b84ee (patch)
tree1af19c7eff529547bd24d08b8047cfac11f89a44
parentrust-toolchain.eclass: add support for mips64el platforms (diff)
downloadgentoo-35c325dde79c4383fe1f7dce7e607c064d8b84ee.tar.gz
gentoo-35c325dde79c4383fe1f7dce7e607c064d8b84ee.tar.bz2
gentoo-35c325dde79c4383fe1f7dce7e607c064d8b84ee.zip
rust-toolchain.eclass: qualify applicable rust_arch_uris with ABI and endianness
For less downloading client-side, as it is likely that only one package in each covered group would work on a given system. See: https://github.com/gentoo/gentoo/pull/31241 Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
-rw-r--r--dev-lang/rust-bin/rust-bin-1.65.0-r1.ebuild2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.66.1-r1.ebuild2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.67.1-r3.ebuild2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.68.2-r2.ebuild2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.69.0-r1.ebuild2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.70.0-r3.ebuild2
-rw-r--r--dev-lang/rust/rust-1.65.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.66.1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.67.1-r1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.68.2.ebuild2
-rw-r--r--dev-lang/rust/rust-1.69.0-r1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.70.0.ebuild2
-rw-r--r--eclass/rust-toolchain.eclass16
13 files changed, 22 insertions, 18 deletions
diff --git a/dev-lang/rust-bin/rust-bin-1.65.0-r1.ebuild b/dev-lang/rust-bin/rust-bin-1.65.0-r1.ebuild
index 217681fdca9e..6dde1cf31349 100644
--- a/dev-lang/rust-bin/rust-bin-1.65.0-r1.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.65.0-r1.ebuild
@@ -21,7 +21,7 @@ SRC_URI+=" sparc? ( ${GENTOO_BIN_BASEURI}/${MY_P}-sparc64-unknown-linux-gnu.tar.
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="stable"
KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
DEPEND=""
diff --git a/dev-lang/rust-bin/rust-bin-1.66.1-r1.ebuild b/dev-lang/rust-bin/rust-bin-1.66.1-r1.ebuild
index 4c965e1f5dd4..f9765ffc184f 100644
--- a/dev-lang/rust-bin/rust-bin-1.66.1-r1.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.66.1-r1.ebuild
@@ -21,7 +21,7 @@ SRC_URI+=" sparc? ( ${GENTOO_BIN_BASEURI}/${MY_P}-sparc64-unknown-linux-gnu.tar.
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="stable"
KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE="clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
DEPEND=""
diff --git a/dev-lang/rust-bin/rust-bin-1.67.1-r3.ebuild b/dev-lang/rust-bin/rust-bin-1.67.1-r3.ebuild
index 610fa6b3862b..1fd8cfadb4bc 100644
--- a/dev-lang/rust-bin/rust-bin-1.67.1-r3.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.67.1-r3.ebuild
@@ -21,7 +21,7 @@ SRC_URI+=" sparc? ( ${GENTOO_BIN_BASEURI}/${MY_P}-sparc64-unknown-linux-gnu.tar.
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="stable"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
DEPEND=""
diff --git a/dev-lang/rust-bin/rust-bin-1.68.2-r2.ebuild b/dev-lang/rust-bin/rust-bin-1.68.2-r2.ebuild
index 452944a8954a..4d3aa7a52e2c 100644
--- a/dev-lang/rust-bin/rust-bin-1.68.2-r2.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.68.2-r2.ebuild
@@ -21,7 +21,7 @@ SRC_URI+=" sparc? ( ${GENTOO_BIN_BASEURI}/${MY_P}-sparc64-unknown-linux-gnu.tar.
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="stable"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
DEPEND=""
diff --git a/dev-lang/rust-bin/rust-bin-1.69.0-r1.ebuild b/dev-lang/rust-bin/rust-bin-1.69.0-r1.ebuild
index 12c4f3640532..4176ec9e5060 100644
--- a/dev-lang/rust-bin/rust-bin-1.69.0-r1.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.69.0-r1.ebuild
@@ -21,7 +21,7 @@ SRC_URI+=" sparc? ( ${GENTOO_BIN_BASEURI}/${MY_P}-sparc64-unknown-linux-gnu.tar.
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="stable"
KEYWORDS="amd64 arm arm64 ~mips ~ppc ppc64 ~riscv ~s390 x86"
-IUSE="clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
DEPEND=""
diff --git a/dev-lang/rust-bin/rust-bin-1.70.0-r3.ebuild b/dev-lang/rust-bin/rust-bin-1.70.0-r3.ebuild
index 327b4fbea0e8..95a02a459a7e 100644
--- a/dev-lang/rust-bin/rust-bin-1.70.0-r3.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.70.0-r3.ebuild
@@ -21,7 +21,7 @@ SRC_URI+=" sparc? ( ${GENTOO_BIN_BASEURI}/${MY_P}-sparc64-unknown-linux-gnu.tar.
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="stable"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
DEPEND=""
diff --git a/dev-lang/rust/rust-1.65.0.ebuild b/dev-lang/rust/rust-1.65.0.ebuild
index 5ea43e34fcae..2d8b9c47d533 100644
--- a/dev-lang/rust/rust-1.65.0.ebuild
+++ b/dev-lang/rust/rust-1.65.0.ebuild
@@ -41,7 +41,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/(-)?}
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-IUSE="clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
+IUSE="big-endian clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
# Please keep the LLVM dependency block separate. Since LLVM is slotted,
# we need to *really* make sure we're not pulling more than one slot
diff --git a/dev-lang/rust/rust-1.66.1.ebuild b/dev-lang/rust/rust-1.66.1.ebuild
index f20dc1060368..970a5f8f50cc 100644
--- a/dev-lang/rust/rust-1.66.1.ebuild
+++ b/dev-lang/rust/rust-1.66.1.ebuild
@@ -41,7 +41,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/(-)?}
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
-IUSE="clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
+IUSE="big-endian clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
# Please keep the LLVM dependency block separate. Since LLVM is slotted,
# we need to *really* make sure we're not pulling more than one slot
diff --git a/dev-lang/rust/rust-1.67.1-r1.ebuild b/dev-lang/rust/rust-1.67.1-r1.ebuild
index 36ce9427fd71..4231d2809591 100644
--- a/dev-lang/rust/rust-1.67.1-r1.ebuild
+++ b/dev-lang/rust/rust-1.67.1-r1.ebuild
@@ -41,7 +41,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/(-)?}
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
-IUSE="clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
+IUSE="big-endian clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
# Please keep the LLVM dependency block separate. Since LLVM is slotted,
# we need to *really* make sure we're not pulling more than one slot
diff --git a/dev-lang/rust/rust-1.68.2.ebuild b/dev-lang/rust/rust-1.68.2.ebuild
index b8df00c94ecd..690e3ab4544e 100644
--- a/dev-lang/rust/rust-1.68.2.ebuild
+++ b/dev-lang/rust/rust-1.68.2.ebuild
@@ -41,7 +41,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/(-)?}
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
-IUSE="clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
+IUSE="big-endian clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
# Please keep the LLVM dependency block separate. Since LLVM is slotted,
# we need to *really* make sure we're not pulling more than one slot
diff --git a/dev-lang/rust/rust-1.69.0-r1.ebuild b/dev-lang/rust/rust-1.69.0-r1.ebuild
index 888c961ff96a..b59ebc386dcf 100644
--- a/dev-lang/rust/rust-1.69.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.69.0-r1.ebuild
@@ -41,7 +41,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/(-)?}
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
-IUSE="clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
+IUSE="big-endian clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
# Please keep the LLVM dependency block separate. Since LLVM is slotted,
# we need to *really* make sure we're not pulling more than one slot
diff --git a/dev-lang/rust/rust-1.70.0.ebuild b/dev-lang/rust/rust-1.70.0.ebuild
index 1f659bb445d7..6a3217a13741 100644
--- a/dev-lang/rust/rust-1.70.0.ebuild
+++ b/dev-lang/rust/rust-1.70.0.ebuild
@@ -41,7 +41,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/(-)?}
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4 UoI-NCSA"
-IUSE="clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind +lto miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
+IUSE="big-endian clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind +lto miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
# Please keep the LLVM dependency block separate. Since LLVM is slotted,
# we need to *really* make sure we're not pulling more than one slot
diff --git a/eclass/rust-toolchain.eclass b/eclass/rust-toolchain.eclass
index c9c0886009a2..0dcafdf9b335 100644
--- a/eclass/rust-toolchain.eclass
+++ b/eclass/rust-toolchain.eclass
@@ -122,15 +122,19 @@ rust_all_arch_uris()
elibc_musl? ( $(rust_arch_uri aarch64-unknown-linux-musl "$@") )
)
mips? (
- $(rust_arch_uri mips-unknown-linux-gnu "$@")
- $(rust_arch_uri mipsel-unknown-linux-gnu "$@")
- $(rust_arch_uri mips64-unknown-linux-gnuabi64 "$@")
- $(rust_arch_uri mips64el-unknown-linux-gnuabi64 "$@")
+ abi_mips_o32? (
+ big-endian? ( $(rust_arch_uri mips-unknown-linux-gnu "$@") )
+ !big-endian? ( $(rust_arch_uri mipsel-unknown-linux-gnu "$@") )
+ )
+ abi_mips_n64? (
+ big-endian? ( $(rust_arch_uri mips64-unknown-linux-gnuabi64 "$@") )
+ !big-endian? ( $(rust_arch_uri mips64el-unknown-linux-gnuabi64 "$@") )
+ )
)
ppc? ( $(rust_arch_uri powerpc-unknown-linux-gnu "$@") )
ppc64? (
- $(rust_arch_uri powerpc64-unknown-linux-gnu "$@")
- $(rust_arch_uri powerpc64le-unknown-linux-gnu "$@")
+ big-endian? ( $(rust_arch_uri powerpc64-unknown-linux-gnu "$@") )
+ !big-endian? ( $(rust_arch_uri powerpc64le-unknown-linux-gnu "$@") )
)
riscv? ( $(rust_arch_uri riscv64gc-unknown-linux-gnu "$@") )
s390? ( $(rust_arch_uri s390x-unknown-linux-gnu "$@") )