summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-11-15 11:46:20 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-11-15 11:46:20 +0000
commit94a1461b77814aa62939cb1b7b7859d9dca99573 (patch)
tree17579d3e4d7314a8c63f27d86fa0889b72f3aefb /x11-libs/fltk/fltk-1.1.7.ebuild
parentAdd arts USE flag (diff)
downloadgentoo-2-94a1461b77814aa62939cb1b7b7859d9dca99573.tar.gz
gentoo-2-94a1461b77814aa62939cb1b7b7859d9dca99573.tar.bz2
gentoo-2-94a1461b77814aa62939cb1b7b7859d9dca99573.zip
Add patch for amd64 by aballier, see bug #154877.
(Portage version: 2.1.2_rc1-r7)
Diffstat (limited to 'x11-libs/fltk/fltk-1.1.7.ebuild')
-rw-r--r--x11-libs/fltk/fltk-1.1.7.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-libs/fltk/fltk-1.1.7.ebuild b/x11-libs/fltk/fltk-1.1.7.ebuild
index 88b0ca65efba..7360e127c26b 100644
--- a/x11-libs/fltk/fltk-1.1.7.ebuild
+++ b/x11-libs/fltk/fltk-1.1.7.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.7.ebuild,v 1.10 2006/08/09 19:49:08 jer Exp $
-
-IUSE="noxft opengl debug"
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.7.ebuild,v 1.11 2006/11/15 11:46:20 nelchael Exp $
inherit eutils toolchain-funcs multilib
@@ -21,6 +19,8 @@ SLOT="${PV_MAJOR}.${PV_MINOR}"
INCDIR=/usr/include/fltk-${SLOT}
LIBDIR=/usr/$(get_libdir)/fltk-${SLOT}
+IUSE="noxft opengl debug"
+
DEPEND="|| ( (
x11-libs/libXext
x11-libs/libICE
@@ -36,7 +36,10 @@ DEPEND="|| ( (
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/libs-1.7.diff || die "patch failed"
+ epatch "${FILESDIR}/libs-1.7.diff" || die "patch failed"
+ use amd64 && {
+ epatch "${FILESDIR}/${P}-amd64.patch" || die "patch failed"
+ }
}
src_compile() {