summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-11-15 11:46:20 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-11-15 11:46:20 +0000
commit94a1461b77814aa62939cb1b7b7859d9dca99573 (patch)
tree17579d3e4d7314a8c63f27d86fa0889b72f3aefb /x11-libs/fltk
parentAdd arts USE flag (diff)
downloadgentoo-2-94a1461b77814aa62939cb1b7b7859d9dca99573.tar.gz
gentoo-2-94a1461b77814aa62939cb1b7b7859d9dca99573.tar.bz2
gentoo-2-94a1461b77814aa62939cb1b7b7859d9dca99573.zip
Add patch for amd64 by aballier, see bug #154877.
(Portage version: 2.1.2_rc1-r7)
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/ChangeLog6
-rw-r--r--x11-libs/fltk/files/fltk-1.1.7-amd64.patch73
-rw-r--r--x11-libs/fltk/fltk-1.1.7.ebuild11
3 files changed, 85 insertions, 5 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index eca14a23387d..d8e3d62a56e3 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/fltk
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.74 2006/08/09 20:26:06 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.75 2006/11/15 11:46:20 nelchael Exp $
+
+ 15 Nov 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/fltk-1.1.7-amd64.patch, fltk-1.1.7.ebuild:
+ Add patch for amd64 by aballier, see bug #154877.
09 Aug 2006; Krzysiek Pawlik <nelchael@gentoo.org> -files/libs-1.6.diff,
-files/Fl_Help_View.cxx.patch, -fltk-1.1.6.ebuild:
diff --git a/x11-libs/fltk/files/fltk-1.1.7-amd64.patch b/x11-libs/fltk/files/fltk-1.1.7-amd64.patch
new file mode 100644
index 000000000000..f1c334dad993
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.1.7-amd64.patch
@@ -0,0 +1,73 @@
+--- fltk-1.1.7/test/cursor.cxx.old 2006-11-12 14:00:36.000000000 +0100
++++ fltk-1.1.7/test/cursor.cxx 2006-11-12 14:00:46.000000000 +0100
+@@ -39,7 +39,7 @@
+ Fl_Hor_Value_Slider *cursor_slider;
+
+ void choice_cb(Fl_Widget *, void *v) {
+- cursor = (Fl_Cursor)(int)v;
++ cursor = (Fl_Cursor)(long)v;
+ cursor_slider->value(cursor);
+ fl_cursor(cursor,fg,bg);
+ }
+--- fltk-1.1.7/test/input.cxx.old 2006-11-12 14:01:27.000000000 +0100
++++ fltk-1.1.7/test/input.cxx 2006-11-12 14:01:37.000000000 +0100
+@@ -61,7 +61,7 @@
+
+ void color_cb(Fl_Widget* button, void* v) {
+ Fl_Color c;
+- switch ((int)v) {
++ switch ((long)v) {
+ case 0: c = FL_BACKGROUND2_COLOR; break;
+ case 1: c = FL_SELECTION_COLOR; break;
+ default: c = FL_FOREGROUND_COLOR; break;
+--- fltk-1.1.7/test/keyboard.cxx.old 2006-11-12 14:02:10.000000000 +0100
++++ fltk-1.1.7/test/keyboard.cxx 2006-11-12 14:02:30.000000000 +0100
+@@ -105,11 +105,11 @@
+ for (int i = 0; i < window->children(); i++) {
+ Fl_Widget* b = window->child(i);
+ if (b->callback() == (Fl_Callback*)key_cb) {
+- int i = int(b->user_data());
++ long i = long(b->user_data());
+ if (!i) i = b->label()[0];
+ ((Fl_Button*)b)->value(Fl::event_key(i));
+ } else if (b->callback() == (Fl_Callback*)shift_cb) {
+- int i = int(b->user_data());
++ long i = long(b->user_data());
+ ((Fl_Button*)b)->value(Fl::event_state(i));
+ }
+ }
+--- fltk-1.1.7/test/line_style.cxx.old 2006-11-12 14:03:00.000000000 +0100
++++ fltk-1.1.7/test/line_style.cxx 2006-11-12 14:03:18.000000000 +0100
+@@ -54,9 +54,9 @@
+ buf[3] = char(sliders[7]->value());
+ buf[4] = 0;
+ fl_line_style(
+- (int)(choice[0]->mvalue()->user_data()) +
+- (int)(choice[1]->mvalue()->user_data()) +
+- (int)(choice[2]->mvalue()->user_data()),
++ (long)(choice[0]->mvalue()->user_data()) +
++ (long)(choice[1]->mvalue()->user_data()) +
++ (long)(choice[2]->mvalue()->user_data()),
+ (int)(sliders[3]->value()),
+ buf);
+ fl_rect(10,10,w()-20,h()-20);
+--- fltk-1.1.7/test/scroll.cxx.old 2006-11-12 14:03:55.000000000 +0100
++++ fltk-1.1.7/test/scroll.cxx 2006-11-12 14:04:19.000000000 +0100
+@@ -71,7 +71,7 @@
+ }
+
+ void type_cb(Fl_Widget*, void* v) {
+- thescroll->type(int(v));
++ thescroll->type(long(v));
+ thescroll->redraw();
+ }
+
+@@ -87,7 +87,7 @@
+ };
+
+ void align_cb(Fl_Widget*, void* v) {
+- thescroll->scrollbar.align(int(v));
++ thescroll->scrollbar.align(long(v));
+ thescroll->redraw();
+ }
+
diff --git a/x11-libs/fltk/fltk-1.1.7.ebuild b/x11-libs/fltk/fltk-1.1.7.ebuild
index 88b0ca65efba..7360e127c26b 100644
--- a/x11-libs/fltk/fltk-1.1.7.ebuild
+++ b/x11-libs/fltk/fltk-1.1.7.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.7.ebuild,v 1.10 2006/08/09 19:49:08 jer Exp $
-
-IUSE="noxft opengl debug"
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.7.ebuild,v 1.11 2006/11/15 11:46:20 nelchael Exp $
inherit eutils toolchain-funcs multilib
@@ -21,6 +19,8 @@ SLOT="${PV_MAJOR}.${PV_MINOR}"
INCDIR=/usr/include/fltk-${SLOT}
LIBDIR=/usr/$(get_libdir)/fltk-${SLOT}
+IUSE="noxft opengl debug"
+
DEPEND="|| ( (
x11-libs/libXext
x11-libs/libICE
@@ -36,7 +36,10 @@ DEPEND="|| ( (
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/libs-1.7.diff || die "patch failed"
+ epatch "${FILESDIR}/libs-1.7.diff" || die "patch failed"
+ use amd64 && {
+ epatch "${FILESDIR}/${P}-amd64.patch" || die "patch failed"
+ }
}
src_compile() {