summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2005-08-24 20:16:00 +0000
committerRenat Lumpau <rl03@gentoo.org>2005-08-24 20:16:00 +0000
commitb0241bb6397bed1e0d102cde026eab4a0fb56012 (patch)
tree9b04a344df63de0e2278719ed02399c7419e505e /www-apps/rt
parentstable on ia64 (diff)
downloadgentoo-2-b0241bb6397bed1e0d102cde026eab4a0fb56012.tar.gz
gentoo-2-b0241bb6397bed1e0d102cde026eab4a0fb56012.tar.bz2
gentoo-2-b0241bb6397bed1e0d102cde026eab4a0fb56012.zip
Fix dependency checking code wrt bug #103481
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-apps/rt')
-rw-r--r--www-apps/rt/ChangeLog6
-rw-r--r--www-apps/rt/Manifest16
-rw-r--r--www-apps/rt/rt-3.2.1.ebuild15
-rw-r--r--www-apps/rt/rt-3.4.2-r1.ebuild10
-rw-r--r--www-apps/rt/rt-3.4.3.ebuild6
5 files changed, 31 insertions, 22 deletions
diff --git a/www-apps/rt/ChangeLog b/www-apps/rt/ChangeLog
index 9031b6b71e38..8d03bbde7a6a 100644
--- a/www-apps/rt/ChangeLog
+++ b/www-apps/rt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/rt
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/ChangeLog,v 1.19 2005/08/23 19:29:07 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/ChangeLog,v 1.20 2005/08/24 20:16:00 rl03 Exp $
+
+ 24 Aug 2005; Renat Lumpau <rl03@gentoo.org> rt-3.2.1.ebuild,
+ rt-3.4.2-r1.ebuild, rt-3.4.3.ebuild:
+ Fix dependency checking code wrt bug #103481
23 Aug 2005; Renat Lumpau <rl03@gentoo.org> rt-3.4.3.ebuild:
Fix enewuser invocation wrt bug #103421
diff --git a/www-apps/rt/Manifest b/www-apps/rt/Manifest
index 9ac93db26cc2..0db9e2bd06a4 100644
--- a/www-apps/rt/Manifest
+++ b/www-apps/rt/Manifest
@@ -1,9 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 2d55314d5a0dc44ed84ff04cda740034 rt-3.4.2-r1.ebuild 5438
-MD5 045002e419f3171a81a06cdd7582b098 rt-3.4.3.ebuild 5500
-MD5 e28b5c19f33196d18983e2db57aad44f rt-3.2.1.ebuild 4217
+MD5 170d55071f8c3eaedc62e7fde8994981 rt-3.4.2-r1.ebuild 5569
+MD5 619d7b8296f9f3049acdc6783efbbdf4 rt-3.4.3.ebuild 5586
+MD5 572c8520d3ec1abf30ec4b2b15ced3f3 rt-3.2.1.ebuild 4359
MD5 783cb55d6cd13c9b2b450180b2f4a7e5 ChangeLog 3480
MD5 224c312cc23d02aa06c26a4da3cc1f90 metadata.xml 221
MD5 af335c7cab7bfc09dbd08feba51d2879 files/digest-rt-3.4.2-r1 61
@@ -19,10 +16,3 @@ MD5 c807deb11e08ab9f37a658bd5e971c7f files/3.4.2/rt.conf.d 405
MD5 54a1cd04dc0d0788ce920d941e5601d0 files/3.4.2/rt.init.d 1019
MD5 bf81df666e02df7b1e6f73ee9908a767 files/3.4.2/reconfig 1206
MD5 73c354dd8ba0f64a74e5c6cd01b33834 files/3.4.2/rt_apache2_fcgi.conf 993
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDC3kdEzitwsaoONoRArzOAJ0VcDUgMpCPDimQa9T0PkdhxSF8zACfbE3n
-xqHg5MX8Yx/2quj5n1qd22o=
-=x1EQ
------END PGP SIGNATURE-----
diff --git a/www-apps/rt/rt-3.2.1.ebuild b/www-apps/rt/rt-3.2.1.ebuild
index 4f7bbaa08762..0ec4088c50ba 100644
--- a/www-apps/rt/rt-3.2.1.ebuild
+++ b/www-apps/rt/rt-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.2.1.ebuild,v 1.6 2005/06/21 02:12:38 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.2.1.ebuild,v 1.7 2005/08/24 20:16:00 rl03 Exp $
inherit webapp eutils
@@ -113,10 +113,17 @@ src_compile() {
" ${files}
# check for missing deps and ask to report if something is broken
- if `make testdeps | grep "MISSING"`; then
- ewarn "Missing Perl dependency, please file a bug in the Gentoo Bugzilla with the information above"
+ /usr/bin/perl ./sbin/rt-test-dependencies --verbose \
+ `use_with mysql` \
+ `use_with postgres pg` > ${T}/t
+ if grep -q "MISSING" ${T}/t; then
+ ewarn "Missing Perl dependency!"
+ ewarn
+ cat ${T}/t
+ ewarn
+ ewarn "Please file a bug in the Gentoo Bugzilla with the information above"
ewarn "and assign it to rl03@gentoo.org"
- die "Missing dependencies"
+ die "Missing dependencies."
fi
}
diff --git a/www-apps/rt/rt-3.4.2-r1.ebuild b/www-apps/rt/rt-3.4.2-r1.ebuild
index 1d9d51d25c2e..ac1c3630cccd 100644
--- a/www-apps/rt/rt-3.4.2-r1.ebuild
+++ b/www-apps/rt/rt-3.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.4.2-r1.ebuild,v 1.6 2005/08/08 22:40:44 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.4.2-r1.ebuild,v 1.7 2005/08/24 20:16:00 rl03 Exp $
inherit webapp eutils
@@ -165,8 +165,14 @@ src_compile() {
--with-web-group=${web}
# check for missing deps and ask to report if something is broken
- if `make testdeps | grep "MISSING"`; then
+ /usr/bin/perl ./sbin/rt-test-dependencies --verbose \
+ `use_with mysql` \
+ `use_with postgres pg` > ${T}/t
+ if grep -q "MISSING" ${T}/t; then
ewarn "Missing Perl dependency!"
+ ewarn
+ cat ${T}/t
+ ewarn
ewarn "Please file a bug in the Gentoo Bugzilla with the information above"
ewarn "and assign it to rl03@gentoo.org"
die "Missing dependencies."
diff --git a/www-apps/rt/rt-3.4.3.ebuild b/www-apps/rt/rt-3.4.3.ebuild
index 43fed3b70a73..446d16d18ade 100644
--- a/www-apps/rt/rt-3.4.3.ebuild
+++ b/www-apps/rt/rt-3.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.4.3.ebuild,v 1.2 2005/08/23 19:29:07 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.4.3.ebuild,v 1.3 2005/08/24 20:16:00 rl03 Exp $
inherit webapp eutils
@@ -166,7 +166,9 @@ src_compile() {
--with-web-group=${web}
# check for missing deps and ask to report if something is broken
- make testdeps > ${T}/t
+ /usr/bin/perl ./sbin/rt-test-dependencies --verbose \
+ `use_with mysql` \
+ `use_with postgres pg` > ${T}/t
if grep -q "MISSING" ${T}/t; then
ewarn "Missing Perl dependency!"
ewarn