summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/rt/rt-3.2.1.ebuild')
-rw-r--r--www-apps/rt/rt-3.2.1.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/www-apps/rt/rt-3.2.1.ebuild b/www-apps/rt/rt-3.2.1.ebuild
index 4f7bbaa08762..0ec4088c50ba 100644
--- a/www-apps/rt/rt-3.2.1.ebuild
+++ b/www-apps/rt/rt-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.2.1.ebuild,v 1.6 2005/06/21 02:12:38 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.2.1.ebuild,v 1.7 2005/08/24 20:16:00 rl03 Exp $
inherit webapp eutils
@@ -113,10 +113,17 @@ src_compile() {
" ${files}
# check for missing deps and ask to report if something is broken
- if `make testdeps | grep "MISSING"`; then
- ewarn "Missing Perl dependency, please file a bug in the Gentoo Bugzilla with the information above"
+ /usr/bin/perl ./sbin/rt-test-dependencies --verbose \
+ `use_with mysql` \
+ `use_with postgres pg` > ${T}/t
+ if grep -q "MISSING" ${T}/t; then
+ ewarn "Missing Perl dependency!"
+ ewarn
+ cat ${T}/t
+ ewarn
+ ewarn "Please file a bug in the Gentoo Bugzilla with the information above"
ewarn "and assign it to rl03@gentoo.org"
- die "Missing dependencies"
+ die "Missing dependencies."
fi
}