summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-11 01:04:30 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-11 01:04:30 +0000
commitc34394d631cfb0c31d87c68524e6329ef66bcd39 (patch)
tree8358d13f77c4dc4dcde3e93a423a4826a82014cf /sys-libs/glibc
parentadd a sanity check to the read #118589 (diff)
downloadgentoo-2-c34394d631cfb0c31d87c68524e6329ef66bcd39.tar.gz
gentoo-2-c34394d631cfb0c31d87c68524e6329ef66bcd39.tar.bz2
gentoo-2-c34394d631cfb0c31d87c68524e6329ef66bcd39.zip
fix header searching when emerging into an empty ROOT #114923
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild9
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild9
2 files changed, 12 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index 0df40cf8e001..a8c3f98d98ff 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.51 2005/12/03 00:55:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.52 2006/01/11 01:04:30 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -671,13 +671,16 @@ src_compile() {
rm -rf ${WORKDIR}/build
mkdir -p ${WORKDIR}/build
cd ${WORKDIR}/build
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
${S}/configure \
--build=${CHOST} \
--host=${CTARGET} \
--disable-profile \
--without-gd \
--without-cvs \
- --with-headers=$(alt_headers) \
+ --with-headers=${headersloc} \
--prefix=$(alt_prefix) \
--mandir=$(alt_prefix)/share/man \
--infodir=$(alt_prefix)/share/info \
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
index 0c0364a7b65a..3deae88ac555 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.22 2005/12/03 00:55:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.23 2006/01/11 01:04:30 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -695,6 +695,9 @@ glibc_do_configure() {
myconf="${myconf} --without-selinux"
fi
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
# Who knows if this works :)
[[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
myconf="${myconf} --without-cvs
@@ -703,7 +706,7 @@ glibc_do_configure() {
--host=${CTARGET}
--disable-profile
--without-gd
- --with-headers=$(alt_headers)
+ --with-headers=${headersloc}
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info