summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index 0df40cf8e001..a8c3f98d98ff 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.51 2005/12/03 00:55:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.52 2006/01/11 01:04:30 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -671,13 +671,16 @@ src_compile() {
rm -rf ${WORKDIR}/build
mkdir -p ${WORKDIR}/build
cd ${WORKDIR}/build
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
${S}/configure \
--build=${CHOST} \
--host=${CTARGET} \
--disable-profile \
--without-gd \
--without-cvs \
- --with-headers=$(alt_headers) \
+ --with-headers=${headersloc} \
--prefix=$(alt_prefix) \
--mandir=$(alt_prefix)/share/man \
--infodir=$(alt_prefix)/share/info \