summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-01-16 13:00:00 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-01-16 13:00:00 +0000
commitb3a4027fc35cd4535418312746b66c2d23ee163a (patch)
tree918e80a4221c9c2be367a087efa2d63970568ca5 /sys-fs
parentDrop old revisions. Restore kde4-base_pkg_setup which was inadvertently dropp... (diff)
downloadgentoo-2-b3a4027fc35cd4535418312746b66c2d23ee163a.tar.gz
gentoo-2-b3a4027fc35cd4535418312746b66c2d23ee163a.tar.bz2
gentoo-2-b3a4027fc35cd4535418312746b66c2d23ee163a.zip
Initial commit of treesize application. Fixes bug #269236
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/treesize/ChangeLog11
-rw-r--r--sys-fs/treesize/files/0.54.1-amd64.patch10
-rw-r--r--sys-fs/treesize/metadata.xml12
-rw-r--r--sys-fs/treesize/treesize-0.54.1.ebuild26
4 files changed, 59 insertions, 0 deletions
diff --git a/sys-fs/treesize/ChangeLog b/sys-fs/treesize/ChangeLog
new file mode 100644
index 000000000000..b48b3a7fe54d
--- /dev/null
+++ b/sys-fs/treesize/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-fs/treesize
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/treesize/ChangeLog,v 1.1 2010/01/16 12:59:59 hwoarang Exp $
+
+*treesize-0.54.1 (16 Jan 2010)
+
+ 16 Jan 2010; <hwoarang@gentoo.org> +files/0.54.1-amd64.patch,
+ +treesize-0.54.1.ebuild, +metadata.xml:
+ Initial commit of treesize application. Fixes bug #269236. Thanks to
+ Justin Lecher (jlec) <jlec@j-schmitz.net> for the ebuild
+
diff --git a/sys-fs/treesize/files/0.54.1-amd64.patch b/sys-fs/treesize/files/0.54.1-amd64.patch
new file mode 100644
index 000000000000..d7d9d787ad39
--- /dev/null
+++ b/sys-fs/treesize/files/0.54.1-amd64.patch
@@ -0,0 +1,10 @@
+--- src/ui-util.c 2007-11-16 22:08:01.000000000 +0100
++++ src/ui-util.c.new 2009-05-09 11:34:59.000000000 +0200
+@@ -18,6 +18,7 @@
+
+ #include "ui-util.h"
+ #include "FAfolderAnalyzer.h"
++#include "support.h"
+ extern GtkWidget *mainWindow;
+
+ gpointer getTVSelectedValue( int element ){
diff --git a/sys-fs/treesize/metadata.xml b/sys-fs/treesize/metadata.xml
new file mode 100644
index 000000000000..87afd6e36004
--- /dev/null
+++ b/sys-fs/treesize/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/sys-fs/treesize/treesize-0.54.1.ebuild b/sys-fs/treesize/treesize-0.54.1.ebuild
new file mode 100644
index 000000000000..3dffc17d5f02
--- /dev/null
+++ b/sys-fs/treesize/treesize-0.54.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/treesize/treesize-0.54.1.ebuild,v 1.1 2010/01/16 12:59:59 hwoarang Exp $
+
+EAPI="2"
+
+inherit base
+
+DESCRIPTION="A disk consumption analyzing tool"
+HOMEPAGE="http://treesize.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}-amd64.patch" )
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installation failed"
+ dodoc NEWS README TODO ChangeLog || die "nothing to read"
+}