summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-04-11 20:08:54 +0000
committerMike Frysinger <vapier@gentoo.org>2010-04-11 20:08:54 +0000
commit31e8e489fd6b8b4457d277e4dd671dd21f7203f3 (patch)
treed7213112899a8669161977a38e84fd97332fa35e /sys-devel/automake
parentRemove SCRIPTS from the environment #312551 by Justin Lecher. (diff)
downloadgentoo-2-31e8e489fd6b8b4457d277e4dd671dd21f7203f3.tar.gz
gentoo-2-31e8e489fd6b8b4457d277e4dd671dd21f7203f3.tar.bz2
gentoo-2-31e8e489fd6b8b4457d277e4dd671dd21f7203f3.zip
old
Diffstat (limited to 'sys-devel/automake')
-rw-r--r--sys-devel/automake/automake-1.10.2.ebuild62
-rw-r--r--sys-devel/automake/automake-1.11.ebuild79
-rw-r--r--sys-devel/automake/automake-1.4_p6.ebuild56
-rw-r--r--sys-devel/automake/automake-1.5.ebuild54
-rw-r--r--sys-devel/automake/automake-1.6.3.ebuild47
-rw-r--r--sys-devel/automake/automake-1.7.9-r1.ebuild50
-rw-r--r--sys-devel/automake/automake-1.8.5-r3.ebuild50
-rw-r--r--sys-devel/automake/automake-1.9.6-r2.ebuild59
8 files changed, 0 insertions, 457 deletions
diff --git a/sys-devel/automake/automake-1.10.2.ebuild b/sys-devel/automake/automake-1.10.2.ebuild
deleted file mode 100644
index fa397c86e77c..000000000000
--- a/sys-devel/automake/automake-1.10.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.10.2.ebuild,v 1.9 2009/03/21 11:42:54 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://sources.redhat.com/automake/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="${PV:0:4}"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND="dev-lang/perl
- >=sys-devel/automake-wrapper-2
- >=sys-devel/autoconf-2.60
- >=sys-apps/texinfo-4.7
- sys-devel/gnuconfig"
-DEPEND="${RDEPEND}
- sys-apps/help2man"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- chmod a+rx tests/*.test
- sed -i \
- -e "s|: (automake)| v${SLOT}: (automake${SLOT})|" \
- doc/automake.texi || die "sed failed"
- mv doc/automake{,${SLOT}}.texi
- sed -i \
- -e "s:automake.info:automake${SLOT}.info:" \
- -e "s:automake.texi:automake${SLOT}.texi:" \
- doc/Makefile.in || die "sed on Makefile.in failed"
- epatch "${FILESDIR}"/${P}-bash4.patch #263068
- export WANT_AUTOCONF=2.5
-}
-
-src_compile() {
- econf --docdir=/usr/share/doc/${PF} || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
-
- # SLOT the docs and junk
- local x
- for x in aclocal automake ; do
- help2man "perl -Ilib ${x}" > ${x}-${SLOT}.1
- doman ${x}-${SLOT}.1
- rm -f "${D}"/usr/bin/${x}
- done
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}
diff --git a/sys-devel/automake/automake-1.11.ebuild b/sys-devel/automake/automake-1.11.ebuild
deleted file mode 100644
index 72711110e014..000000000000
--- a/sys-devel/automake/automake-1.11.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.11.ebuild,v 1.1 2009/05/17 20:50:21 flameeyes Exp $
-
-inherit eutils versionator
-
-if [[ ${PV/_beta} == ${PV} ]]; then
- MY_P=${P}
- SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-else
- MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
- MY_P="${PN}-${MY_PV}"
-
- # Alpha/beta releases are not distributed on the usual mirrors.
- SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.bz2"
-fi
-
-S="${WORKDIR}/${MY_P}"
-
-# Use Gentoo versioning for slotting.
-SLOT="${PV:0:4}"
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://sources.redhat.com/automake/"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND="dev-lang/perl
- >=sys-devel/automake-wrapper-3-r2
- >=sys-devel/autoconf-2.62
- >=sys-apps/texinfo-4.7
- sys-devel/gnuconfig"
-DEPEND="${RDEPEND}
- sys-apps/help2man"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- chmod a+rx tests/*.test
- sed -i \
- -e "s|: (automake)| v${SLOT}: (automake${SLOT})|" \
- doc/automake.texi || die "sed failed"
- mv doc/automake{,${SLOT}}.texi
- sed -i \
- -e "s:automake.info:automake${SLOT}.info:" \
- -e "s:automake.texi:automake${SLOT}.texi:" \
- doc/Makefile.in || die "sed on Makefile.in failed"
- export WANT_AUTOCONF=2.5
-}
-
-src_compile() {
- econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
- emake \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
-
- local x
- for x in aclocal automake; do
- help2man "perl -Ilib ${x}" > doc/${x}-${SLOT}.1
- done
-}
-
-src_install() {
- emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
-
- rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- local x
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}
diff --git a/sys-devel/automake/automake-1.4_p6.ebuild b/sys-devel/automake/automake-1.4_p6.ebuild
deleted file mode 100644
index 8d7f0ee0ddf5..000000000000
--- a/sys-devel/automake/automake-1.4_p6.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.4_p6.ebuild,v 1.25 2008/11/23 14:56:33 vapier Exp $
-
-inherit eutils
-
-MY_P="${P/_/-}"
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://sources.redhat.com/automake/"
-SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="${PV:0:3}"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="dev-lang/perl
- sys-devel/automake-wrapper
- >=sys-devel/autoconf-2.59-r6
- sys-devel/gnuconfig"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/automake-1.4-nls-nuisances.patch #121151
- epatch "${FILESDIR}"/automake-1.4-libtoolize.patch
- epatch "${FILESDIR}"/automake-1.4-subdirs-89656.patch
- epatch "${FILESDIR}"/automake-1.4-ansi2knr-stdlib.patch
- sed -i 's:error\.test::' tests/Makefile.in #79529
- sed -i \
- -e "/^@setfilename/s|automake|automake${SLOT}|" \
- -e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
- -e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
- automake.texi || die "sed failed"
- export WANT_AUTOCONF=2.5
-}
-
-src_install() {
- emake install DESTDIR="${D}" \
- pkgdatadir=/usr/share/automake-${SLOT} \
- m4datadir=/usr/share/aclocal-${SLOT} \
- || die
- rm -f "${D}"/usr/bin/{aclocal,automake}
- dosym automake-${SLOT} /usr/share/automake
-
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
- doinfo *.info
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}
diff --git a/sys-devel/automake/automake-1.5.ebuild b/sys-devel/automake/automake-1.5.ebuild
deleted file mode 100644
index fdc9fbf6ad92..000000000000
--- a/sys-devel/automake/automake-1.5.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.5.ebuild,v 1.31 2009/05/29 23:41:11 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://sources.redhat.com/automake/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="${PV:0:3}"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="dev-lang/perl
- sys-devel/automake-wrapper
- >=sys-devel/autoconf-2.59-r6
- sys-devel/gnuconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/automake-1.4-nls-nuisances.patch #121151
- epatch "${FILESDIR}"/${P}-target_hook.patch
- epatch "${FILESDIR}"/${P}-slot.patch
- epatch "${FILESDIR}"/${P}-test-fixes.patch #79505
- epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
- sed -i \
- -e "/^@setfilename/s|automake|automake${SLOT}|" \
- -e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
- -e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
- automake.texi || die "sed failed"
- export WANT_AUTOCONF=2.5
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "make install failed"
-
- local x=
- for x in aclocal automake ; do
- mv "${D}"/usr/bin/${x}{,-${SLOT}} || die "rename ${x}"
- mv "${D}"/usr/share/${x}{,-${SLOT}} || die "move ${x}"
- done
-
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
- doinfo *.info
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}
diff --git a/sys-devel/automake/automake-1.6.3.ebuild b/sys-devel/automake/automake-1.6.3.ebuild
deleted file mode 100644
index fca1848d3539..000000000000
--- a/sys-devel/automake/automake-1.6.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.6.3.ebuild,v 1.40 2009/05/29 23:41:10 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://sources.redhat.com/automake/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="${PV:0:3}"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="dev-lang/perl
- sys-devel/automake-wrapper
- >=sys-devel/autoconf-2.59-r6
- sys-devel/gnuconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e "/^@setfilename/s|automake|automake${SLOT}|" \
- -e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
- -e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
- automake.texi || die "sed failed"
- epatch "${FILESDIR}"/${P}-test-fixes.patch #159557
- epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
- export WANT_AUTOCONF=2.5
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- rm -f "${D}"/usr/bin/{aclocal,automake}
-
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
- doinfo *.info
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- local x=
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}
diff --git a/sys-devel/automake/automake-1.7.9-r1.ebuild b/sys-devel/automake/automake-1.7.9-r1.ebuild
deleted file mode 100644
index 5867e7baa280..000000000000
--- a/sys-devel/automake/automake-1.7.9-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.7.9-r1.ebuild,v 1.19 2009/05/29 23:41:11 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://sources.redhat.com/automake/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="${PV:0:3}"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="dev-lang/perl
- sys-devel/automake-wrapper
- >=sys-devel/autoconf-2.59-r6
- sys-devel/gnuconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e "/^@setfilename/s|automake|automake${SLOT}|" \
- -e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
- -e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
- automake.texi || die "sed texi failed"
- epatch "${FILESDIR}"/${P}-infopage-namechange.patch
- epatch "${FILESDIR}"/${P}-test-fixes.patch
- epatch "${FILESDIR}"/${PN}-1.9.6-subst-test.patch #222225
- epatch "${FILESDIR}"/${P}-libtool-2.patch #257544
- epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
- export WANT_AUTOCONF=2.5
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- rm -f "${D}"/usr/bin/{aclocal,automake}
-
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
- doinfo automake${SLOT}.info
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- local x=
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}
diff --git a/sys-devel/automake/automake-1.8.5-r3.ebuild b/sys-devel/automake/automake-1.8.5-r3.ebuild
deleted file mode 100644
index 3727618ae0fb..000000000000
--- a/sys-devel/automake/automake-1.8.5-r3.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.8.5-r3.ebuild,v 1.19 2009/05/29 23:41:11 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://sources.redhat.com/automake/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="${PV:0:3}"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="dev-lang/perl
- sys-devel/automake-wrapper
- >=sys-devel/autoconf-2.59-r6
- sys-devel/gnuconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e "/^@setfilename/s|automake|automake${SLOT}|" \
- -e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
- -e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
- doc/automake.texi || die "sed failed"
- epatch "${FILESDIR}"/${PN}-1.8.2-infopage-namechange.patch
- epatch "${FILESDIR}"/${P}-test-fixes.patch #159557
- epatch "${FILESDIR}"/${PN}-1.9.6-aclocal7-test-sleep.patch #197366
- epatch "${FILESDIR}"/${PN}-1.9.6-subst-test.patch #222225
- epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
- export WANT_AUTOCONF=2.5
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- rm -f "${D}"/usr/bin/{aclocal,automake}
-
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
- doinfo doc/*.info*
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- local x=
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}
diff --git a/sys-devel/automake/automake-1.9.6-r2.ebuild b/sys-devel/automake/automake-1.9.6-r2.ebuild
deleted file mode 100644
index 4a7b91529756..000000000000
--- a/sys-devel/automake/automake-1.9.6-r2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.6-r2.ebuild,v 1.20 2009/05/29 23:41:10 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://sources.redhat.com/automake/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="${PV:0:3}"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND="dev-lang/perl
- sys-devel/automake-wrapper
- >=sys-devel/autoconf-2.59-r6
- >=sys-apps/texinfo-4.7
- sys-devel/gnuconfig"
-DEPEND="${RDEPEND}
- sys-apps/help2man"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e "/^@setfilename/s|automake|automake${SLOT}|" \
- -e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
- -e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
- doc/automake.texi || die "sed failed"
- epatch "${FILESDIR}"/${PN}-1.9.6-infopage-namechange.patch
- epatch "${FILESDIR}"/${P}-include-dir-prefix.patch #107435
- epatch "${FILESDIR}"/${P}-ignore-comments.patch #126388
- epatch "${FILESDIR}"/${P}-aclocal7-test-sleep.patch #197366
- epatch "${FILESDIR}"/${PN}-1.9.6-subst-test.patch #222225
- epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
- export WANT_AUTOCONF=2.5
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- local x
- for x in aclocal automake ; do
- help2man "perl -Ilib ${x}" > ${x}-${SLOT}.1
- doman ${x}-${SLOT}.1
- rm -f "${D}"/usr/bin/${x}
- done
-
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
- doinfo doc/*.info*
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}