summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake/automake-1.6.3.ebuild')
-rw-r--r--sys-devel/automake/automake-1.6.3.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/sys-devel/automake/automake-1.6.3.ebuild b/sys-devel/automake/automake-1.6.3.ebuild
deleted file mode 100644
index fca1848d3539..000000000000
--- a/sys-devel/automake/automake-1.6.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.6.3.ebuild,v 1.40 2009/05/29 23:41:10 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="http://sources.redhat.com/automake/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="${PV:0:3}"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="dev-lang/perl
- sys-devel/automake-wrapper
- >=sys-devel/autoconf-2.59-r6
- sys-devel/gnuconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e "/^@setfilename/s|automake|automake${SLOT}|" \
- -e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
- -e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
- automake.texi || die "sed failed"
- epatch "${FILESDIR}"/${P}-test-fixes.patch #159557
- epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
- export WANT_AUTOCONF=2.5
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- rm -f "${D}"/usr/bin/{aclocal,automake}
-
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
- doinfo *.info
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- local x=
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}