summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-07-22 09:51:30 +0000
committerJustin Lecher <jlec@gentoo.org>2014-07-22 09:51:30 +0000
commit28d1ebd4845bec7985ba28301eda41898f5324a4 (patch)
tree9ff7f03424ab103f66a97583b233811c3038126c /sci-chemistry
parentRemove duplicate dependency wrt bug #511054. (diff)
downloadgentoo-2-28d1ebd4845bec7985ba28301eda41898f5324a4.tar.gz
gentoo-2-28d1ebd4845bec7985ba28301eda41898f5324a4.tar.bz2
gentoo-2-28d1ebd4845bec7985ba28301eda41898f5324a4.zip
sci-chemistry/pymol-apbs-plugin: Fix double prefix
(Portage version: 2.2.10/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol-apbs-plugin/ChangeLog8
-rw-r--r--sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-2.1_p26-r1.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/sci-chemistry/pymol-apbs-plugin/ChangeLog b/sci-chemistry/pymol-apbs-plugin/ChangeLog
index ee80eea0b1dc..87a011009289 100644
--- a/sci-chemistry/pymol-apbs-plugin/ChangeLog
+++ b/sci-chemistry/pymol-apbs-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pymol-apbs-plugin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/ChangeLog,v 1.12 2014/07/10 09:29:13 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/ChangeLog,v 1.13 2014/07/22 09:51:30 jlec Exp $
+
+*pymol-apbs-plugin-2.1_p26-r1 (22 Jul 2014)
+
+ 22 Jul 2014; Justin Lecher <jlec@gentoo.org>
+ +pymol-apbs-plugin-2.1_p26-r1.ebuild:
+ Fix double prefix
10 Jul 2014; Chema Alonso <nimiux@gentoo.org>
pymol-apbs-plugin-2.1_p26.ebuild:
diff --git a/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-2.1_p26-r1.ebuild b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-2.1_p26-r1.ebuild
new file mode 100644
index 000000000000..9098926397c5
--- /dev/null
+++ b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-2.1_p26-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-2.1_p26-r1.ebuild,v 1.1 2014/07/22 09:51:30 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+MY_PV="${PV##*_p}"
+
+DESCRIPTION="APBS plugin for pymol"
+HOMEPAGE="http://sourceforge.net/projects/pymolapbsplugin/"
+SRC_URI="http://sourceforge.net/p/pymolapbsplugin/code/${MY_PV}/tree/trunk/src/apbsplugin.py?format=raw -> ${P}.py"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="pymol"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ sci-chemistry/apbs
+ sci-chemistry/pdb2pqr
+ !<sci-chemistry/pymol-1.2.2-r1"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ mkdir "${S}"
+ cp "${DISTDIR}"/${P}.py "${S}"/
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tcltk8.6.patch
+ python_copy_sources
+}
+
+src_install() {
+ installation() {
+ cd "${BUILD_DIR}" || die
+ sed \
+ -e "s:^APBS_BINARY_LOCATION.*:APBS_BINARY_LOCATION = \"${EPREFIX}/usr/bin/apbs\":g" \
+ -e "s:^APBS_PSIZE_LOCATION.*:APBS_PSIZE_LOCATION = \"$(python_get_sitedir)/pdb2pqr/src/\":g" \
+ -e "s:^APBS_PDB2PQR_LOCATION.*:APBS_PDB2PQR_LOCATION = \"$(python_get_sitedir)/pdb2pqr/\":g" \
+ -e "s:^TEMPORARY_FILE_DIR.*:TEMPORARY_FILE_DIR = \"./\":g" \
+ ${P}.py > apbs_tools.py || die
+
+ python_moduleinto pmg_tk/startup
+ python_domodule apbs_tools.py
+ python_optimize
+ }
+ python_parallel_foreach_impl installation
+}