summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-12-20 20:07:24 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-12-20 20:07:24 +0000
commit18fa2e0693837f4452a3b351c86fe47db2dae85f (patch)
tree73d29c380b7c55ae4d483eb55e522060297ce367 /net-p2p
parentAdd missing pycrypto dep (#447980 with Markos Chandras agreement) (diff)
downloadgentoo-2-18fa2e0693837f4452a3b351c86fe47db2dae85f.tar.gz
gentoo-2-18fa2e0693837f4452a3b351c86fe47db2dae85f.tar.bz2
gentoo-2-18fa2e0693837f4452a3b351c86fe47db2dae85f.zip
Add PYTHON_ABI to -lboost_python. Bug #444522
(Portage version: 2.1.11.37/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/ChangeLog7
-rw-r--r--net-p2p/deluge/deluge-1.3.5-r1.ebuild16
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild14
3 files changed, 31 insertions, 6 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index 4ac9a80a384e..6dcf3697e073 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.178 2012/12/17 20:40:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.179 2012/12/20 20:07:24 hwoarang Exp $
+
+ 20 Dec 2012; Markos Chandras <hwoarang@gentoo.org> deluge-1.3.5-r1.ebuild,
+ deluge-9999.ebuild:
+ Add $PYTHON_ABI to -lboost_python. Bug #444522. Thanks to Avner Peled
+ <avnerus@gmail.com> for the patch
*deluge-1.3.5-r1 (17 Dec 2012)
diff --git a/net-p2p/deluge/deluge-1.3.5-r1.ebuild b/net-p2p/deluge/deluge-1.3.5-r1.ebuild
index 7a7ba7d88ee9..e3be2a40e997 100644
--- a/net-p2p/deluge/deluge-1.3.5-r1.ebuild
+++ b/net-p2p/deluge/deluge-1.3.5-r1.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.5-r1.ebuild,v 1.1 2012/12/17 20:40:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.5-r1.ebuild,v 1.2 2012/12/20 20:07:24 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-inherit distutils eutils flag-o-matic
+inherit distutils eutils flag-o-matic python
DESCRIPTION="BitTorrent client with a client/server model."
HOMEPAGE="http://deluge-torrent.org/"
@@ -37,14 +39,22 @@ RDEPEND="${DEPEND}
setproctitle? ( dev-python/setproctitle )
webinterface? ( dev-python/mako )"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
pkg_setup() {
append-ldflags $(no-as-needed)
- python_set_active_version 2
python_pkg_setup
}
src_prepare() {
distutils_src_prepare
+ fix_boost_python() {
+ # fix libboost_python. It needs the python ABI on the side. #444522
+ sed -i -e "s/'boost_python'/'boost_python-${PYTHON_ABI}'/" setup.py \
+ || die "sed setup.py failed"
+ }
+ python_execute_function -s fix_boost_python
+
python_convert_shebangs -r 2 .
epatch "${FILESDIR}/${P}-rb_libtorrent-disable-python-bindings"
}
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index 09afd06a3efa..9226f3acd9e8 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-9999.ebuild,v 1.29 2012/04/22 17:37:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-9999.ebuild,v 1.30 2012/12/20 20:07:24 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
inherit distutils flag-o-matic git-2
@@ -39,14 +41,22 @@ RDEPEND="${DEPEND}
setproctitle? ( dev-python/setproctitle )
webinterface? ( dev-python/mako )"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
pkg_setup() {
append-ldflags $(no-as-needed)
- python_set_active_version 2
python_pkg_setup
}
src_prepare() {
distutils_src_prepare
+ fix_boost_python() {
+ # fix libboost_python. It needs the python ABI on the side. #444522
+ sed -i -e "s/'boost_python'/'boost_python-${PYTHON_ABI}'/" setup.py \
+ || die "sed setup.py failed"
+ }
+ python_execute_function -s fix_boost_python
+
python_convert_shebangs -r 2 .
}