summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/deluge/deluge-1.3.5-r1.ebuild')
-rw-r--r--net-p2p/deluge/deluge-1.3.5-r1.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/net-p2p/deluge/deluge-1.3.5-r1.ebuild b/net-p2p/deluge/deluge-1.3.5-r1.ebuild
index 7a7ba7d88ee9..e3be2a40e997 100644
--- a/net-p2p/deluge/deluge-1.3.5-r1.ebuild
+++ b/net-p2p/deluge/deluge-1.3.5-r1.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.5-r1.ebuild,v 1.1 2012/12/17 20:40:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.5-r1.ebuild,v 1.2 2012/12/20 20:07:24 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-inherit distutils eutils flag-o-matic
+inherit distutils eutils flag-o-matic python
DESCRIPTION="BitTorrent client with a client/server model."
HOMEPAGE="http://deluge-torrent.org/"
@@ -37,14 +39,22 @@ RDEPEND="${DEPEND}
setproctitle? ( dev-python/setproctitle )
webinterface? ( dev-python/mako )"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
pkg_setup() {
append-ldflags $(no-as-needed)
- python_set_active_version 2
python_pkg_setup
}
src_prepare() {
distutils_src_prepare
+ fix_boost_python() {
+ # fix libboost_python. It needs the python ABI on the side. #444522
+ sed -i -e "s/'boost_python'/'boost_python-${PYTHON_ABI}'/" setup.py \
+ || die "sed setup.py failed"
+ }
+ python_execute_function -s fix_boost_python
+
python_convert_shebangs -r 2 .
epatch "${FILESDIR}/${P}-rb_libtorrent-disable-python-bindings"
}