summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-06-12 20:49:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-06-12 20:49:46 +0000
commit5a9cf58f015ad3c2dfbbc42e42a5ec8526c93928 (patch)
treeac0614e6a4818aff7c973942a450ea2ae3f96431 /media-video/cclive
parentversion bump (diff)
downloadgentoo-2-5a9cf58f015ad3c2dfbbc42e42a5ec8526c93928.tar.gz
gentoo-2-5a9cf58f015ad3c2dfbbc42e42a5ec8526c93928.tar.bz2
gentoo-2-5a9cf58f015ad3c2dfbbc42e42a5ec8526c93928.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video/cclive')
-rw-r--r--media-video/cclive/ChangeLog7
-rw-r--r--media-video/cclive/cclive-0.6.3.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-video/cclive/ChangeLog b/media-video/cclive/ChangeLog
index c7dc9be4e705..0d0544ccaaad 100644
--- a/media-video/cclive/ChangeLog
+++ b/media-video/cclive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cclive
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.17 2010/04/12 10:10:05 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.18 2010/06/12 20:49:46 aballier Exp $
+
+*cclive-0.6.3 (12 Jun 2010)
+
+ 12 Jun 2010; Alexis Ballier <aballier@gentoo.org> +cclive-0.6.3.ebuild:
+ version bump
*cclive-0.6.2 (12 Apr 2010)
diff --git a/media-video/cclive/cclive-0.6.3.ebuild b/media-video/cclive/cclive-0.6.3.ebuild
new file mode 100644
index 000000000000..22e2a3b1b183
--- /dev/null
+++ b/media-video/cclive/cclive-0.6.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/cclive-0.6.3.ebuild,v 1.1 2010/06/12 20:49:46 aballier Exp $
+
+EAPI=2
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://code.google.com/p/cclive/"
+SRC_URI="http://cclive.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test offensive"
+
+RDEPEND=">=media-libs/quvi-0.1.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-man \
+ $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}
+
+src_test() {
+ local value
+
+ ewarn "Tests require internet connection in order to work."
+
+ use offensive && value="true" || value="false"
+ ADULT_OK="${value}" emake check || die "emake test failed"
+}