summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/cclive/cclive-0.6.3.ebuild')
-rw-r--r--media-video/cclive/cclive-0.6.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-video/cclive/cclive-0.6.3.ebuild b/media-video/cclive/cclive-0.6.3.ebuild
new file mode 100644
index 000000000000..22e2a3b1b183
--- /dev/null
+++ b/media-video/cclive/cclive-0.6.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/cclive-0.6.3.ebuild,v 1.1 2010/06/12 20:49:46 aballier Exp $
+
+EAPI=2
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://code.google.com/p/cclive/"
+SRC_URI="http://cclive.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test offensive"
+
+RDEPEND=">=media-libs/quvi-0.1.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-man \
+ $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}
+
+src_test() {
+ local value
+
+ ewarn "Tests require internet connection in order to work."
+
+ use offensive && value="true" || value="false"
+ ADULT_OK="${value}" emake check || die "emake test failed"
+}