summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-08-26 23:35:12 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-08-26 23:35:12 +0000
commit5bec7195186ed7e6bfa2124a1fce0d2c770b9988 (patch)
tree6f5aa3fee7540e88541fb16dce5af9d75c025cd9 /games-puzzle
parentold (diff)
downloadgentoo-2-5bec7195186ed7e6bfa2124a1fce0d2c770b9988.tar.gz
gentoo-2-5bec7195186ed7e6bfa2124a1fce0d2c770b9988.tar.bz2
gentoo-2-5bec7195186ed7e6bfa2124a1fce0d2c770b9988.zip
fix python handling wrt #482578
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/monsterz/ChangeLog9
-rw-r--r--games-puzzle/monsterz/monsterz-0.7.1-r3.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/games-puzzle/monsterz/ChangeLog b/games-puzzle/monsterz/ChangeLog
index 5443b975a781..5c323383bdf9 100644
--- a/games-puzzle/monsterz/ChangeLog
+++ b/games-puzzle/monsterz/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/monsterz
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.29 2012/09/19 02:01:24 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.30 2013/08/26 23:35:11 hasufell Exp $
+
+*monsterz-0.7.1-r3 (26 Aug 2013)
+
+ 26 Aug 2013; Julian Ospald <hasufell@gentoo.org> +monsterz-0.7.1-r3.ebuild:
+ fix python handling wrt #482578
19 Sep 2012; Michael Sterrett <mr_bones_@gentoo.org> monsterz-0.7.1-r2.ebuild:
any mod support will do
diff --git a/games-puzzle/monsterz/monsterz-0.7.1-r3.ebuild b/games-puzzle/monsterz/monsterz-0.7.1-r3.ebuild
new file mode 100644
index 000000000000..c3199fadc81e
--- /dev/null
+++ b/games-puzzle/monsterz/monsterz-0.7.1-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/monsterz-0.7.1-r3.ebuild,v 1.1 2013/08/26 23:35:12 hasufell Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 )
+inherit eutils games python-r1
+
+DESCRIPTION="a little puzzle game, similar to the famous Bejeweled or Zookeeper"
+HOMEPAGE="http://sam.zoy.org/projects/monsterz/"
+SRC_URI="http://sam.zoy.org/projects/monsterz/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-64bit.patch \
+ "${FILESDIR}"/${P}-blit.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ monsterz.py || die "sed failed"
+ rm Makefile || die
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r graphics sound
+ newgamesbin monsterz.py ${PN}
+ newicon graphics/icon.png ${PN}.png
+ make_desktop_entry ${PN} Monsterz
+ dodoc README AUTHORS TODO
+ python_replicate_script "${ED%/}${GAMES_BINDIR}"/monsterz
+ prepgamesdirs
+}