summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-10-26 07:31:51 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-10-26 07:31:51 +0000
commita331c36163681d7c7326a0eba3f8d22c03f48b81 (patch)
tree144c6094cf9a120ba7664012fe2a32092030e91a /games-emulation
parentVersion bump but masked since it is too broken, bug #438560. Pin gstreamer de... (diff)
downloadgentoo-2-a331c36163681d7c7326a0eba3f8d22c03f48b81.tar.gz
gentoo-2-a331c36163681d7c7326a0eba3f8d22c03f48b81.tar.bz2
gentoo-2-a331c36163681d7c7326a0eba3f8d22c03f48b81.zip
Fix build with gcc-4.7 Bug #424111
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fceux/ChangeLog7
-rw-r--r--games-emulation/fceux/fceux-2.1.5.ebuild24
-rw-r--r--games-emulation/fceux/files/fceux-2.1.5-gcc47.patch22
3 files changed, 40 insertions, 13 deletions
diff --git a/games-emulation/fceux/ChangeLog b/games-emulation/fceux/ChangeLog
index e337de54910b..b08eaea69e6d 100644
--- a/games-emulation/fceux/ChangeLog
+++ b/games-emulation/fceux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/fceux
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.15 2012/03/12 19:12:43 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.16 2012/10/26 07:31:49 tupone Exp $
+
+ 26 Oct 2012; Alfredo Tupone <tupone@gentoo.org> fceux-2.1.5.ebuild,
+ +files/fceux-2.1.5-gcc47.patch:
+ Fix build with gcc-4.7 Bug #424111 by Diego
+ Migration to EAPI=4
12 Mar 2012; Michael Sterrett <mr_bones_@gentoo.org> fceux-2.1.5.ebuild,
+files/fceux-2.1.5-gcc46.patch:
diff --git a/games-emulation/fceux/fceux-2.1.5.ebuild b/games-emulation/fceux/fceux-2.1.5.ebuild
index 738d3b190d39..3fa83866cc51 100644
--- a/games-emulation/fceux/fceux-2.1.5.ebuild
+++ b/games-emulation/fceux/fceux-2.1.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.1.5.ebuild,v 1.3 2012/03/12 19:12:43 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.1.5.ebuild,v 1.4 2012/10/26 07:31:49 tupone Exp $
-EAPI=2
+EAPI=4
inherit eutils scons-utils games
DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
@@ -20,6 +20,8 @@ RDEPEND="lua? ( dev-lang/lua )
x11-libs/gtk+:2
sys-libs/zlib
gnome-extra/zenity"
+DEPEND="${RDEPEND}"
+
# Note: zenity is "almost" optional. It is possible to compile and run fceux
# without zenity, but file dialogs will not work.
@@ -28,7 +30,8 @@ S=${WORKDIR}/fceu${PV}
src_prepare() {
epatch \
"${FILESDIR}"/${P}-underlink.patch \
- "${FILESDIR}"/${P}-gcc46.patch
+ "${FILESDIR}"/${P}-gcc46.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
# mentioned in bug #335836
if ! use lua ; then
sed -i -e '/_S9XLUA_H/d' SConstruct || die
@@ -39,19 +42,16 @@ src_compile() {
escons \
CREATE_AVI=1 \
$(use_scons opengl OPENGL) \
- $(use_scons lua LUA) \
- || die "scons failed"
+ $(use_scons lua LUA)
}
src_install() {
- dogamesbin bin/fceux || die
-
- doman documentation/fceux.6 || die
- dodoc Authors.txt changelog.txt TODO-PROJECT
+ dogamesbin bin/fceux
- # Extra documentation
- insinto "/usr/share/doc/${PF}/"
- doins -r bin/fceux.chm documentation
+ doman documentation/fceux.6
+ docompress -x /usr/share/doc/${PF}/documentation
+ docompress -x /usr/share/doc/${PF}/fceux.chm
+ dodoc -r Authors.txt changelog.txt TODO-PROJECT bin/fceux.chm documentation
rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
prepgamesdirs
diff --git a/games-emulation/fceux/files/fceux-2.1.5-gcc47.patch b/games-emulation/fceux/files/fceux-2.1.5-gcc47.patch
new file mode 100644
index 000000000000..0b15cc89ad5c
--- /dev/null
+++ b/games-emulation/fceux/files/fceux-2.1.5-gcc47.patch
@@ -0,0 +1,22 @@
+--- src/utils/endian.h.old 2012-10-26 09:07:24.000000000 +0200
++++ src/utils/endian.h 2012-10-26 09:08:25.000000000 +0200
+@@ -93,19 +93,6 @@
+ }
+ }
+
+-template<typename T>
+-int writele(T *Bufo, EMUFILE*os)
+-{
+- CTASSERT(sizeof(T)==1||sizeof(T)==2||sizeof(T)==4||sizeof(T)==8);
+- switch(sizeof(T)) {
+- case 1: return write8le((uint8*)Bufo,os);
+- case 2: return write16le((uint16*)Bufo,os);
+- case 4: return write32le((uint32*)Bufo,os);
+- case 8: return write64le((uint64*)Bufo,os);
+- default:
+- return 0;
+- }
+-}
+
+ #endif //__FCEU_ENDIAN
+