summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/fceux/fceux-2.1.5.ebuild')
-rw-r--r--games-emulation/fceux/fceux-2.1.5.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/games-emulation/fceux/fceux-2.1.5.ebuild b/games-emulation/fceux/fceux-2.1.5.ebuild
index 738d3b190d39..3fa83866cc51 100644
--- a/games-emulation/fceux/fceux-2.1.5.ebuild
+++ b/games-emulation/fceux/fceux-2.1.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.1.5.ebuild,v 1.3 2012/03/12 19:12:43 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.1.5.ebuild,v 1.4 2012/10/26 07:31:49 tupone Exp $
-EAPI=2
+EAPI=4
inherit eutils scons-utils games
DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
@@ -20,6 +20,8 @@ RDEPEND="lua? ( dev-lang/lua )
x11-libs/gtk+:2
sys-libs/zlib
gnome-extra/zenity"
+DEPEND="${RDEPEND}"
+
# Note: zenity is "almost" optional. It is possible to compile and run fceux
# without zenity, but file dialogs will not work.
@@ -28,7 +30,8 @@ S=${WORKDIR}/fceu${PV}
src_prepare() {
epatch \
"${FILESDIR}"/${P}-underlink.patch \
- "${FILESDIR}"/${P}-gcc46.patch
+ "${FILESDIR}"/${P}-gcc46.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
# mentioned in bug #335836
if ! use lua ; then
sed -i -e '/_S9XLUA_H/d' SConstruct || die
@@ -39,19 +42,16 @@ src_compile() {
escons \
CREATE_AVI=1 \
$(use_scons opengl OPENGL) \
- $(use_scons lua LUA) \
- || die "scons failed"
+ $(use_scons lua LUA)
}
src_install() {
- dogamesbin bin/fceux || die
-
- doman documentation/fceux.6 || die
- dodoc Authors.txt changelog.txt TODO-PROJECT
+ dogamesbin bin/fceux
- # Extra documentation
- insinto "/usr/share/doc/${PF}/"
- doins -r bin/fceux.chm documentation
+ doman documentation/fceux.6
+ docompress -x /usr/share/doc/${PF}/documentation
+ docompress -x /usr/share/doc/${PF}/fceux.chm
+ dodoc -r Authors.txt changelog.txt TODO-PROJECT bin/fceux.chm documentation
rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
prepgamesdirs