summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 00:11:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 00:11:43 +0000
commit1c6d751414813e08cc79999b77062512d6f94bbc (patch)
treecaad9deea66521909246b148b581bf2dbd6df3b0 /dev-python/pyyaml
parentUse PYTHON_DEPEND instead of NEED_PYTHON. (diff)
downloadgentoo-2-1c6d751414813e08cc79999b77062512d6f94bbc.tar.gz
gentoo-2-1c6d751414813e08cc79999b77062512d6f94bbc.tar.bz2
gentoo-2-1c6d751414813e08cc79999b77062512d6f94bbc.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/pyyaml')
-rw-r--r--dev-python/pyyaml/files/pyyaml-3.05-libyaml.diff23
-rw-r--r--dev-python/pyyaml/pyyaml-3.08-r1.ebuild36
-rw-r--r--dev-python/pyyaml/pyyaml-3.08.ebuild33
3 files changed, 0 insertions, 92 deletions
diff --git a/dev-python/pyyaml/files/pyyaml-3.05-libyaml.diff b/dev-python/pyyaml/files/pyyaml-3.05-libyaml.diff
deleted file mode 100644
index 1c1a3a690e12..000000000000
--- a/dev-python/pyyaml/files/pyyaml-3.05-libyaml.diff
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -Naur PyYAML-3.05.orig/setup.py PyYAML-3.05/setup.py
---- PyYAML-3.05.orig/setup.py 2007-05-12 23:28:55.000000000 +0200
-+++ PyYAML-3.05/setup.py 2007-10-16 02:29:57.000000000 +0200
-@@ -31,6 +31,8 @@
- ]
-
- from distutils.core import setup
-+from distutils.extension import Extension
-+from Pyrex.Distutils import build_ext
-
- if __name__ == '__main__':
-
-@@ -49,5 +51,10 @@
-
- package_dir={'': 'lib'},
- packages=['yaml'],
-+ ext_modules=[
-+ Extension("_yaml", ["ext/_yaml.pyx"], libraries=['yaml']),
-+ ],
-+
-+ cmdclass = {'build_ext': build_ext}
- )
-
diff --git a/dev-python/pyyaml/pyyaml-3.08-r1.ebuild b/dev-python/pyyaml/pyyaml-3.08-r1.ebuild
deleted file mode 100644
index dc8e4cb05a57..000000000000
--- a/dev-python/pyyaml/pyyaml-3.08-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyyaml/pyyaml-3.08-r1.ebuild,v 1.1 2009/08/29 23:21:53 arfrever Exp $
-
-EAPI="2"
-
-NEED_PYTHON="2.3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-MY_P="PyYAML-${PV}"
-
-DESCRIPTION="YAML parser and emitter for Python"
-HOMEPAGE="http://pyyaml.org/wiki/PyYAML"
-SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="examples libyaml"
-
-DEPEND="libyaml? ( dev-libs/libyaml dev-python/pyrex )"
-RDEPEND="libyaml? ( dev-libs/libyaml )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="yaml"
-
-src_install() {
- distutils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/.
- fi
-}
diff --git a/dev-python/pyyaml/pyyaml-3.08.ebuild b/dev-python/pyyaml/pyyaml-3.08.ebuild
deleted file mode 100644
index 62a1e645e036..000000000000
--- a/dev-python/pyyaml/pyyaml-3.08.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyyaml/pyyaml-3.08.ebuild,v 1.7 2009/09/05 19:06:56 ranger Exp $
-
-NEED_PYTHON="2.3"
-
-inherit distutils
-
-MY_P="PyYAML-${PV}"
-
-DESCRIPTION="YAML parser and emitter for Python"
-HOMEPAGE="http://pyyaml.org/wiki/PyYAML"
-SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86"
-IUSE="examples libyaml"
-
-DEPEND="libyaml? ( dev-libs/libyaml dev-python/pyrex )"
-RDEPEND="libyaml? ( dev-libs/libyaml )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="yaml"
-
-src_install() {
- distutils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/.
- fi
-}