summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2006-05-27 13:52:17 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2006-05-27 13:52:17 +0000
commit9e51f00dcecec84418df8c78edb2fb6f892c984f (patch)
tree4b7a4205a6bac5e55e4ccb0ef3aadfd8e2b3e87b /dev-python/kid
parentInitial import, closes bug #121427 (diff)
downloadgentoo-2-9e51f00dcecec84418df8c78edb2fb6f892c984f.tar.gz
gentoo-2-9e51f00dcecec84418df8c78edb2fb6f892c984f.tar.bz2
gentoo-2-9e51f00dcecec84418df8c78edb2fb6f892c984f.zip
Version bump. Closing bug #134509, thanks to Nicolas Lalevee.
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'dev-python/kid')
-rw-r--r--dev-python/kid/ChangeLog7
-rw-r--r--dev-python/kid/files/digest-kid-0.82
-rw-r--r--dev-python/kid/files/digest-kid-0.9.13
-rw-r--r--dev-python/kid/kid-0.9.1.ebuild42
4 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/kid/ChangeLog b/dev-python/kid/ChangeLog
index 93537cff0068..00ce66ccbb1a 100644
--- a/dev-python/kid/ChangeLog
+++ b/dev-python/kid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/kid
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/ChangeLog,v 1.6 2006/04/01 15:04:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/ChangeLog,v 1.7 2006/05/27 13:52:17 lucass Exp $
+
+*kid-0.9.1 (27 May 2006)
+
+ 27 May 2006; Lukasz Strzygowski <lucass@gentoo.org> +kid-0.9.1.ebuild:
+ Version bump. Closing bug #134509, thanks to Nicolas Lalevee.
01 Apr 2006; Aron Griffis <agriffis@gentoo.org> kid-0.9.ebuild:
Mark 0.9 ~ia64
diff --git a/dev-python/kid/files/digest-kid-0.8 b/dev-python/kid/files/digest-kid-0.8
index 2d002094ca01..2e3f5ccb2b16 100644
--- a/dev-python/kid/files/digest-kid-0.8
+++ b/dev-python/kid/files/digest-kid-0.8
@@ -1 +1,3 @@
MD5 3ebc1df08ceb636fb5102fc3a1f6448e kid-0.8.tar.gz 172307
+RMD160 0325ff1ccc9a451ce3f873ae35f9fdd7d1424ff1 kid-0.8.tar.gz 172307
+SHA256 f00fdbb5abde5649e2e097a9426f49b224b0e2567fa7bef08593f585d3766e56 kid-0.8.tar.gz 172307
diff --git a/dev-python/kid/files/digest-kid-0.9.1 b/dev-python/kid/files/digest-kid-0.9.1
new file mode 100644
index 000000000000..201dd65afd34
--- /dev/null
+++ b/dev-python/kid/files/digest-kid-0.9.1
@@ -0,0 +1,3 @@
+MD5 7a8ccde54f4e1bfe78220dfb8e04f2ba kid-0.9.1.tar.gz 89529
+RMD160 0c6fea321371092227cff4974060f6b930957e4e kid-0.9.1.tar.gz 89529
+SHA256 3e38749a0f269ab12d1dfd898ff8377f94fb2f5b4c4c05b900d355fd9f539e72 kid-0.9.1.tar.gz 89529
diff --git a/dev-python/kid/kid-0.9.1.ebuild b/dev-python/kid/kid-0.9.1.ebuild
new file mode 100644
index 000000000000..5d8fd0e9d0ba
--- /dev/null
+++ b/dev-python/kid/kid-0.9.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/kid-0.9.1.ebuild,v 1.1 2006/05/27 13:52:17 lucass Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A simple and Pythonic XML template language"
+SRC_URI="http://kid.lesscode.org/dist/${PV}/${P}.tar.gz"
+HOMEPAGE="http://kid.lesscode.org/"
+
+KEYWORDS="~amd64 ~ia64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/elementtree-1.2.6"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # use distutils instead of egg
+ epatch ${FILESDIR}/kid-0.9-ezsetup-gentoo.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ dobin bin/*
+
+ dohtml -r doc/html/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}
+
+pkg_postinst() {
+ einfo "Installing dev-python/celementtree may enhance performance."
+}
+