summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kid/kid-0.9.1.ebuild')
-rw-r--r--dev-python/kid/kid-0.9.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/kid/kid-0.9.1.ebuild b/dev-python/kid/kid-0.9.1.ebuild
new file mode 100644
index 000000000000..5d8fd0e9d0ba
--- /dev/null
+++ b/dev-python/kid/kid-0.9.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/kid-0.9.1.ebuild,v 1.1 2006/05/27 13:52:17 lucass Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A simple and Pythonic XML template language"
+SRC_URI="http://kid.lesscode.org/dist/${PV}/${P}.tar.gz"
+HOMEPAGE="http://kid.lesscode.org/"
+
+KEYWORDS="~amd64 ~ia64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/elementtree-1.2.6"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # use distutils instead of egg
+ epatch ${FILESDIR}/kid-0.9-ezsetup-gentoo.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ dobin bin/*
+
+ dohtml -r doc/html/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}
+
+pkg_postinst() {
+ einfo "Installing dev-python/celementtree may enhance performance."
+}
+